MyBookLive 2TB suddenly disappeared and inaccesable

Hi there,

After a day of frustration, browising internet and reading a lot of (sort of) similar (and unanswered) posts I thought I try my luck here…


Yesterday evening I was streaming my movies from my WD MBL 2tb to my WDTVLive without  a single problem.
This morning I woke up…turned on my PC and tried to access my public folder to delete some stuff…

Guess what happend??? Not much, as the drive was unaccesable…After some more investigation I noticed i couldn’t reach it via my WDTVLive, the WD2GO website and via my wd apps on either…

How this could happen?? Really have no idea (evil midgets bashing on my nas while I’m asleep???)

Anyway…this is what I have and what I tried:

  • Conecting directly to power socket in wall - didnt help

  • changing UTP cable with a 100% sure working one - no succes

  • power cycle reboot - no succes

  • pressed the reset button with a cocktail pricker, paperclip and a needle - al didn’t to*

  • changed dns settings settings on my modem - no luck 

  • connecting the MBL directly to my modem (instead of the router) - made no difference

  • Tried pinging the device - unfortunat

  • Arc -A command - didn’t feel the need to popup

  • dancing around the device and praying to whoever would listen - no luck either

My setup:

  • modem (Huawey) - Router - MBL and PC (all cabled)

When I unplug the device and power it on I get a blue led on the front and I can hear it spinning up.
Then I get a whiteish LED.Call me crazy but when I change my positions it could also be yelloww/greenish.

Really out of ideas guys. I might sound like I’m having a fun time, thrust me it’s the helpless feeling kickin in…

Please check the front LED and match it with the closest color to the manual and see what they mean.

Also check the back LEDs.

Post your findings.

Front LED: I would say white, doesn’t seem to be mentioned in the manual.

Back LED’s: lower one Orange, top one green flickering.

The manual on page 12 & 128 says that WHITE indicates a firmware update in progress.    While there was an update sent yesterday, since you reported this on October 6, I doubt that’s the issue  (unless, of course, you hadn’t already updated to what, then, was the latest release…)

Hmmm so what would make sence in this situation…I can’t access the device…Should I leave it powered on and wait 24h?

Firmware updates take 15 minutes, tops.   Point is, if it happened to actually be updating the firmware and you yanked the power while it was doing that, you probably trashed the drive.

Okay, but I probably will never find out as I am not able to access the device? It would make sense that resetting the device should fix that problem. 

I have no idea on what to do now? Has no one experienced this problem??

It’s not possible to reset the device until it’s booted up.   The reset button is actually software-controlled.

Okay so anyone got a suggetsion on what to do next?

If under warranty, RMA.

If not, DIY…

Debrick MyBookLive v2.0


Sympathy post from me - I’ve had the same thing happen and despite my best efforts I cannot get the MBL working correctly again. Occasionally it appears on my network when connected to my router, mostly not. Occasionally I can access the GUI, mostly not. Occasionally I can access the drive and GUI when connected to my PC via a network cable, but mostly not. Sometimes I see the white light during startup, but the product always goes to blue, slowly flashing after a while and is then inaccessible.

I’m going down the RMA route as fortunately the NAS is still under warranty. While I can’t 100% link this to the firmware update that was pushed out, I’ll switch off auto-update in the future and stick with a firmware that I know works. My broadband is slow (~1MB) so downloading the 130MB+ update takes ages.

All disappointing as the product has fulfilled my expectations to this point (serving music to my Sonos system), and suddenly I’m RMA’ing something that probably has no hardware fault.


This sounds familiar except I have no light showing on the front of mine. It was disabled way back when I did a previous firmware update (But the drive functioned just fine).