Mybook world - blue ring - any ideas on how to get data off drives


#1

I have a Mybook  1 TB WD Blue ring drive.  It has failed and I would like to get the data off.  I have heard of issues that the Controller board may be bad!  I tried plugging the drives directly to another PC using cables but this did not work.  I also tried using a new Mybook world 2TB  enclosure and plugged both drives into this unit and that did not work.  Any ideas on how to get access to drive data? 


#2

Through one of our data recovery partners. 

http://support.wdc.com/recovery/index.asp?wdc_lang=en


#3

They want minimum of $600 to access data on  two good drives!  Seems a little crazy to me.  If I could find a used system to buy and recover data seems like this would be the better route!


#4

My drives were configured as  RAID 1 (mirror) so I was able to connect one of my drives to my computer and boot with a Linux Live CD  (I used Ubuntu).  Once booted  you should be able to mount the RAID (4th) partition using command “mount -t ext3 /dev/sdb4 /mnt”   sdb may not be the same on your machine…so whatever the partition is…use that

Also…If you use the Ubuntu Live CD  simply change to superuser by typing in the command “su”  it will prompt you for a password…if you don’t know the password change it by typing “passwd su”

Once you are superuser then you should be able to access all your folders.

Good luck!!