MyBook Word (blue rings) failing - overheating

Following a power outage and after power returned, I found my MyBook model WD5000G3032-001 (500GB) wasn’t working even though the blue lights were on. I shut down the drive for a while and when I powered it up again it worked for a while but then failed again later. This became a pattern as the drive would always work for a while if I powered it down for a few minutes before turning it back on, but would never remain accessible.

I tried using the web-based internal configuration software and used it to download and install the latest software. It made no difference. The error messages indicated that the network drive could no longer be seen while in failure mode. The web-based configuration software also becomes inaccessible in failure mode.

Eventually I noticed the drive was very warm to hot and suspected a heat related fault so I opened the case and directed an electric fan at the drive. This allowed me to recover the data from the drive without it failing.

Obviously it’s not practical to leave an electric fan running to cool the drive since I run the network drive 24/7 for a couple of small game servers.

I have the technical expertise to physically replace the drive and I also managed to use Acronis to make a backup of the whole drive using the options to backup sector-by-sector and to also backup the unallocated space since I read elsewhere that important data is saved in the unallocated space.

Is it practical to just get a new 500G WD drive, restore the data to it and put it into the old drive case?

Better yet, is it possible to do this with a 1TB drive and then expand the data partition (I have GPartEd Live) to take advantage of the extra storage space?

And would there be any advantage in using a new (and more expensive) WD Red drive as a replacement in this case?

Or is there some simple way of forcing the drive to ignore the overheating or at least allow it to become a bit hotter than normal before forcing a shutdown?

The power supply might be burned, try calling tech support first to see if you can get a replacement.