MyBook Studio Studio Edition II 2TB keeps disconnecting


#1

I just bought a new Studio Ed II with the intention of storing my huge Aperture library and I encaountered several problems since the beginning:

1 - the very moment I unboxed the drive and plugged to my MacBook 2.53 15" it made no sign of life. I tried to unplug and reconnect the FW800 cable but no solution. Then I unplugged and tried on another power plug for the power adapter in order to clearify if it was my UPS device causing malfunction. No luck in other power socket until I started turning the small AC power plug that fits in the drive’s backside. So, from what is seems, this initial failure was caused by some sorte of “power contact” inside the drive. I then tried again on the initial placement nearby the laptop and finally started to work.

2 - I then installed the Drive Manager and set up the Raid 1 preparing the Aperture lib transfer. And this operation toke a lot of time in the beginning. Trasfer rate was terribly poor and it took 10 mins to accelerate to a stated and proper speed.

3 - After completing the transfer I started working quite fine (not suprisingly fast but acceptable) with Aperture for at least 4 days. After this very short frame of time, after a night with the MacBook operative and Aperture kept running I found, the next morning, the Studio Ed. completely off and of course not more visible through the finder. Aperture had several warning messages stating it was unable to find the library and then no chance to save the last progress I made the day before. I pressed the power on button on the backside of the drive and it went online but since then the drive now, after about 15mins of inactivity or after the MacBook turn off the display (witout going in sleep mode since I disabled it) the MyBook disconnects.

This is the most disturbing problem ever since I cannot relay on working on it with a delicate archive like the Aperture lib. Also, even if the drive gets back online after I press the button, the WD Drive Manager icon on the menu bar ain’t showing up, even after a log-out / log-in. The only way I have to bring the Manager active is to reinstall it from the original CD (ver. 2.25).

Originally the MyBook was connected with FW800 directly to the MacBook Pro and another FW400 drive was connected from the MyBook. Even if the MyBook disconnects and turns off I can still see and work with the FW400 device so I’m quite sure is not a problem of power but of some sort of internal drive feature.

Of coure I downloaded the latest firmware and installed it with no problems during the process. I Also disabled the “sleep disks option” in the Energy Saver Snow Leopard preferences but no luck so far.

In the end I’d like to know if I have to consoder this one a defective unit I have to ask replace of or if there’s a sort of hotfix or conflict I have to consider but since it really worked without these problems for at least 4 days I’m quite clueless.

Thanks.


#2

Your issues with your drive may stem from power problems.  That said, what model power supply came with your drive?  Does it output +12V DC at 3A?  Do your orient your drive upright or horizontal?  Your drive needs to be upright such that the WD logo on the sides is upright.  Also, did the RAID change ever finish?  Most computers can complete the RAID change within 1-3 minutes.


#3

Yes, the actual power adapter that came with the drive is providing an output of 12V and 3A. The Drive itself is placed in a standup position, where you can clearly read the WD metal logo on both sides. And I had no problems the moment I changed the raid setup from 0 to 1. The operation took one minute or so and ended flawlessly.

During this time I tested a solution I found somewhere on the net, by creating an empty txt document and “touching” it through a launchd service every 7 minutes.

This operation worked for almost a week but now it’s back on the issue. The unit simply turns itself off , deactivating the indicator light in front and, of course, disappearing from the Snow Leopard desktop. After that I can only operate on the power button and turn it on.

I tried also on different macs, all with Snow Leopard and the “sleep disk if possible” option off and the behavior is the same.

Am I facing an hardware problem I have to deal with italian WD support? After what I read through other Mac-oriented forums this is a problem other people is experiencing from the same model so, I’m just guessing, maybe a new firmware update and a newer, much newer version of the Drive Manager could help a little bit after two years of operative systems updates.

Let me know what to do. By now I cannot relay on this product for storing my work.


#4

I have had an almost identical experience. My drive stayed up long enough for me to transfer 2TB of family video files. Now it only stays connected irractically. I have put in an warranty claim, but I hate to send the drive in with all of my media on it.


#5

Same problem here. I’ve got 4 My Book Studio Edition II 2TB - 3 at work and one at home. ALL of them have the same problem. Sometimes they stay connected and accessible, sometimes they ‘go to sleep’ after 10 minutes, with no reason. All of them with FW800 connections; computers attached with Snow Leopard or Leopard, always up-to-date.

I thought I had a solution: first switching the disc, then the computer… but not a big improvement after all.

Two of them are connected to the same computer - one (the second on the chain) has been on without any problem  for the last 3/4 days, the first on the chain (the one physically plugged) keeps switching off.

I’m in charge on buying new equipment in my company. Used to be almost like an evangelist for WD products, but seriously considering changing my mind.

Is this the good product I thought it was or just another unreliable hard drive?


message.jpg

Just while I’m typing, this message popped-up but the disc is NOT in use and on the top of that I DO NOT WANT TO POWER IT OFF!!! And this is related only to one of the two discs! The other one has no problem.


#6

I have a simlar issue.  I learn that the drive has been dismounted when Norton Ghost begins alerting me that my backups failed … because the backup destination no longer exists.  Power reset on the external drive (temporarily) resolves the issue … until it decides to disconnect again. 

Haven’t been able to determine whether it is a specific event that causes this, or if it is a timing issue (drive goes to sleep?)  My power settings (Windows 7 Ultimate, Windows XP Pro SP3) are set to “Never” power down HDD’s.  But it seems to happen every 24-48 hours.

Looking forward to finding a solution. :neutral_face:


#7

This is the topic I was getting on to find a solution for. I have the exact same problem. Every time i access my iPhoto Library located on the drive, it disconnects and I receive a message stating that the drive was disconnected improperly and your data may have been lost or corrupted. It is very frustrating and happens every time the last couple of batches of photos I’ve tried to upload from my camera.  I have to go find my iPhoto Library and then it is fine again until I try again to upload the photos.


#8

Do you have the same issue when using USB or FireWire?  Also, are you using the 36W power supply?


#9

Same issue! :cry:

I bought a Studio Edition II 4TB to use it as Time Machine drive but sometimes it unmount itself. The number of hours after that it unmount isn’t the same: 5, 14 or 30 hours.

I use it in RAID 1 mode, with FW800 cable and with its power supply (12V - 3.0A).

What can I do with it? It’s useless as backup drive if it unmount itself randomly.


#10

did you guys find a solution.  My Book ES 2TB when transfering files (HD Movies) to another drive, i don’t how, but the drive disconnects and connects again.  The message says “source of File missing” off course, the drive from where it was pulling from, disconnects.  Any ideas or fixs?


#11

I have the same disconnect problem with my two MyBook Studio Edition II drives, connecting over firewire on a PPC Mac. One disconnects several times a day, the other a little less often; I feel this is a firmware issue.


#12

Oh dear…

Just got my Studio Edition II up and running, just sat using my iMAC and got the message:

WD My Book Media is in use and cannot be powered off

A quick look on the internet found this thread.

Not good.

Is there a fix or do I sent this back to Ebuyer while I still can?


#13

I have a conjecture

I sometimes see a message of the sort “will shut down if not cool” and I can feel that it is not at all hot; but this might be the very reason it ‘disconnects’.


#14

I have had this problem with a MyBook drive.  I searched the web and found that you had to re-set the USB ports.  This is done by powering down the computer, disconecting all the USB ports, pulling out the power cord and holding the power button on my power mac for 20s.

I then re-connected everything and powered up and my drive stays mounted.  The problem re-occurred a month later and a repeat cured it again.


#15

I’m seeing the disconnect problem over firewire


#16

An update (having had the drive a week).

On my iMAC (2009 21.5" with latest version of Snow Leopard) I seem to have got rid of the disconnecting problem by removing the WD Drive manager software.

The reason I removed it was that in Snow Leopard the software throws an error every 10 secs (you can see this in the console logfile) which prevents the iMac from sleeping.

I contacted WD (have had 6 or so emails from them since) who said to day that the software will be updated by their engineers so that it is compatible.

Then I saw this thread:

http://community.wdc.com/t5/External-Drives-for-Mac/Western-Digital-Drive-Manager-amp-Snow-Leopard/td-p/2579/page/7

And the final post states that it wont!

So although the drive works fine without the software (except monitoring the raid array presumably) I think I may return the drive - as Im not impressed by WD’s responses or attitude to this product.

Anyone know of a good alternative??  I see Buffalo do something similar, the latest version having USB3 (which would hopefully be handy for my next MAC!) - anything else reliable and MAC compatible?


#17

http://support.wdc.com/product/download.asp?groupid=114&sid=61&lang=en

states

Supported Operating Systems

  • Mac OS 10.4.x or higher
  • Mac OS 10.5.x
  • MAC OSX 10.6.x(Snow Leopard)

not that I believe this.

End of life… ? how sad


#18

Hi,

I saw that, and noticed the release date of the software is Dec 2008 (i.e. pre Snow Leopard)

Also have you seen the page for the firmware - which isn’t stated as compatible!

http://support.wdc.com/product/download.asp?groupid=114&sid=103&lang=en

It is sad when its end of life when Ive only had it a week - and Im completely gobsmacked they arent going to support Snow Leopard when its still a current drive - let alone Lion which is out in the Summer!


#19

I wonder if the MyBook Studio Edition II uses the Oxford 936 chip-set and if one could use other firmware intended for this Chip? Would it work, would one lose the case lights?


#20

I just picked up a 2TB “MyBook Mac” WD HD a couple of weeks ago. I switched off the VCD thing from mounting on my Mac. Transferring files went fine.

I wanted this drive to hold all my videos, which i think plugged into my PS3 using USB2.0.

It has been randomly been disconnecting while viewing videos.

I tried a different USB 2 cable and a different power adaptor (from an older WesternDigital MyBook HD i own), but it didn’t help.

What’s going on here ? is the drive going to sleep ? is it a USB issue ? is it overheating ?

Cheers