MyBook Studio II 6TB won't power up anymore

Hi there,

I’ve been using a WD MyBook Studio II 6TB for a few years but over the weekend my iMac and attached MyBook powered off during a power outage. Ever since I can’t get my MyBook turned back on again.

The setup:

The MyBook is attached to an iMac using FireWire 800.

What I tried so far:

  • Turn it off and on again :wink:

  • Replaced the power adapter of the MyBook

  • Replaced the FireWire cable between MyBook and iMac

  • I removed all power sources and then plugged back in, booted up the iMac, powered the MyBook and then conncected the FireWire cable between them. Nothing. DiskUtil doesn’t show anything either. I tried pressing and press-and-holding the power button on the MyBook but even though something inside seems to be on when it’s powered (it warms up, sounds/feels like it’s on) the light on the frontside never goes on or doesn’t even flash. There’s just NO light.

  • I attached another MyBook (older 2 TB model) to the MyBook Studio II 6 TB in a DaisyChain configuration, the second drive (the 2 TB model) mounted on the desktop. I concluded that the MyBook Studio II 6TB still forwards power, and the DaisyChain datalink, but doesn’t mount it’s own drives.

So I think something in the enclosure (RAID controller?) of the MyBook 6TB is dead, and maybe/hopefully my drives and data are still intact.

Question:  Would it be possible to use these drives in another similar enclosure and access the files? They are 2 drives apparently in a RAID 0 configuration (the drive was using all 6 TB of space to store data).

How can I rebuild the RAID configuration on another device and attach these drives to access the data? Is it even possible? Any other suggestions or useful idea’s on how to get the data back are welcome! Thanks!

P.S. I made a support ticket for this, the drive is still in warranty. But right now the data is more important to me than the device.

Welcome to the Community.

Unfortunately, a RAID 0 array does not provide fault tolerance in case of a disk or controller failure. I would recommend contacting a specialized data recovery service company for inspection and assessment.