Mybook studio appears as unformatted since security update - Help!


#1

Hi,
I hope one of you guys can help me with my problem. I have an iMac running 10.6.2 and use a MyBook Studio 1GB connected via Firewire800 for my time machine backups and to store movies… on two partitions. All used to work fine until I installed the latest security update a few days ago.
Since then I can’t connect to the hard drive anymore. Whenever I boot my Mac I get the message that the disk I inserted can’t be read and I get the options to initialise, ignore or eject. When I open disk utility it recognises the hard drive but states it is unformatted (which is not true).
I plugged the hard drive via USB into my Macbook - same message. I tried repairing the disk permissions on my iMac - no difference. I can’t repair any permissions on the external drive as it is all greyed out. Also tried resetting the parameter RAM - no success.
Any suggestions how I could get back my data on the external drive?


#2

Do you hvae the option of testing the drive with another mac? The latest securtiy update didn’t involve any changes related to what you are describing: http://support.apple.com/kb/HT4004