MyBook Studio 2TB BRICKED by update


#1

Yesterday  I downloaded the latest firmware updater to apply to a MyPassport I have, and that updated fine, but I noticed there was a firmware update available for my MyBook Studio 2TB, which I applied as well. The one compelling reason to upgrade was to be able to hide the VCD and the VCD tool needed the latest firmware. Anyway, I followed the recommended procedure for updating the firmware, which appeared to work. I power cycled the drive, unhooked it from the USB port, waited for a lot longer than 10 seconds after which I hooked it up again and it appeared to work. I’m not sure it mounted, but SmartWare saw it. I proceeded to make the VCD invisible, pressed “apply” and followed the instructions again. The drive never mounted again. The screen got scrambled and the power light won’t go on. I think it’s ludicrous that WD puts out a firmware update or vcd tool that is even capable of failing in such a way that it’ll brick a drive.

I’ve tried using the firmware updater to reapply the new firmware and it will see the drive, but fail to update it. I tried it from a Windows machine and the updater crashes right after clicking whichever button it is you press to initiate the FW download. All I know is WD bricked my drive and I can’t seem to get it working again.

Any ideas? All help is deeply appreciated!

Hardware used: MacBook Pro 5,1, MyBook Studio 2TB, Direct connection to onboard USB.


Bricked My Book Studio 2TB
#2

When you power cycled it did you also unplug the power also? I think that is mentioned on updating Windows externals.

Joe


#3

Yup. Pulled the plug after waiting a couple of minutes past the point the process was over.


#4

I know this sounds dumb. Do you have access to a Windows PC or Boot Camp? Some have fixed these firmware issues on Macs by running the update on a Windows PC.

Joe


#5

Thanks for your answer. Yup. I tried re-updating the firmware from Bootcamp (XP SP3) and the updater crashes right before downloading the firmware. It will recognize there’s a drive connected, same as the updater on 10.6, but it simply crashes. On 10.6 the updater will download the firmware and try to apply it, but it invariably fails at the start of the process.


#6

Sorry I can’t offer any more ideas.

Joe


#7

JCPinzon wrote:

Thanks for your answer. Yup. I tried re-updating the firmware from Bootcamp (XP SP3) and the updater crashes right before downloading the firmware. It will recognize there’s a drive connected, same as the updater on 10.6, but it simply crashes. On 10.6 the updater will download the firmware and try to apply it, but it invariably fails at the start of the process.

Try updating using this file:

http://www.wdc.com/global/webtracking/index.asp?id=102&url=http://download.wdc.com/smartware/Studio_Firmware_Updater_v1.012(1.0.8.0).zip

The My Book Studio is not supported by the universal firmware updater at this time.