MyBook Studio 2 and new drive formatting

Have a client that has a 4 year old MyBook Studio 2 that drive B went bad.  Replaced the old drive with an identical drive.  When I went to instal the drive the unit will not mount to the MacMini.  If I open up Western Digital RAID Manager it shows a green light and both Disk Statuses are good.  Now when I open up the Finder window it does not show the WD unit as it did before.  So my question is what do I need to do in order to get this disk to show up again with all data that was originally on there to stay there or did he just loose all music and movies that was on the original drive.  I would have assumed it was set up as a RAID 1 configuration 4 years ago but it now tells me that it is set as a RAID 0.  Any help would be extremely helpful.




Have you tried to use the unit on a different compueter? Maybe one with a different OS.

I tried to plug the unit into my MacBook Pro with Mountain Lion and it brought up Disk Utility and wanted me to reformat the drive.  When I plugged it back into the Mac Mini nothing.   After getting confirmation from the client I was told to wipe the drive and all music and movies and then reformat to RAID 1 and that’s where the day ended.