MyBook: partitions could not be accessed nor deleted

Hi all,

After unboxing, I created two partitions (OS X extended and FAT). After an hour, the partitions could not be accessed anymore. Thus, I tried to delete them using wd drive utilities which does not work either (neither on a mac nor on a PC). Error message: "Das Laufwerk konnte nicht gelöscht werden.“ (german for drive could not be deleted.)

Additional information:
Macbook Air (late 2010) with usb 2.0
OS: El Capitan
My Book with usb 3.0

Any ideas?


Did you try physically disconnecting and connecting your unit again? The sleep timer could have been triggered, making the partitions inaccessible.

yes and I did try to put in another usb and even in several other PCs (windows-based). I will probably send it back.

Next problem. The RMA cannot be processed.

“There was a system error while processing the request. Please try again in a
few minutes. If necessary, you may also contact our support team for

In theory, that all looks so good (online community, phone/online support, online RMA…) but nothing really helps …

Dis you tried “partition” tab using Mac’s Disk Utility?