MyBook Live world edition II disappears from network

i have 2 device, the My Book Live world Edition II and the MyCloud device

ever since i had both devices on the same network, the MyBook Live started to malfunction. it mainly disappears from the network and i can not access it anymore.

is this because i have both devices on the network ?

i tried to fix static IP address for the MyBook device, but this did not help at all. 

please help as i need the MyBook in the network and data on it is not accessible at all.


Kareem-Zahran wrote:

i have 2 device, the My Book Live world Edition II

…there’s no such thing.

There’s a My Book World Edition II

There’s a My Book Live.

Which do you have?

I can think of no reason they shouldn’t coexist…  I have 8 NASes on my network simultaneosly with no issues.   If you’re using Static IP, make sure you’re using UNIQUE addresses, not used by ANYTHING on your network.

If you’re using DHCP, ensure your router is assigning appropriate addresses to both devices.

I have the mybook world edition II

I am not assigning static IP
I am currently using the DHCP option
It seems that there is a problem with the DHCP as the my book only disappears if it is with the mycloud on the same network, i am not a networking pro. So i need help in knowing the IP address to use in setting the static IP.

Can you help me ?

This might help you:

I used this process and it worked. It really is not difficult, just follow the directions. Drives are up and working better than ever, but I am not using them as media servers.

All users of WD MyBook World Edition II (white light) have problems with firmware 1.1.16 and 1.1.18 with freezing the device and WD won’t help them to fix this BUG and release new firmware. The problem is in Twonky and Mionet. I communicated more then two weeks with WD Support and they ignore our problems! Somebody closed the problem Drive Becomes Un-Accessible After short use , however it was not solved.

Here is an update guide from dzentai how to fix this problem till we are waiting 9 months for new firmware which should fix this BUG permanently.

In the web configuration switch to Advanced Mode, then on the System tab using the Advanced button check the SSH Access checkbox on the top of the page, then Submit.

Using Putty or any other SSH client connect to your NAS’s IP address, and log in using “root” as username, and “welc0me” as password!

Now you are inside your NAS.

Type the following on the prompt (this will move/save the startup scripts to the /root/ folder and disable running of mionet and twonky main program and miocrawler it is unnecessary):

mv /etc/init.d/S9M_mionet /root/

mv /etc/init.d/S97twonkyserver /root/

mv /usr/mionet/bin/cvm /root/

mv /usr/mionet/changeNotifySocket /root/

mv /usr/mionet/plugin/miocrawler/miocrawler /root/

then reboot your NAS with