MyBook Live & Windows 7 Laptop

Hi there,

I’m still waiting to get ADSL set up in my new apartment (and get the router supplied by the ISP), but I bought a 3TB MBL in anticipation.

I have tried 2 combinations of setups: MBL connected to Laptop using supplied cable & MBL connected to a network switch which is also connected to Laptop - there is no WAN connection (I tried using a bridged wireless 3G modem connection but that just seemed too complex for now).

I can see the drive fine, it appears in my ‘Network’ under My Computer and the WD Software can see it, and I can connect and set up shares etc fine, but I can’t seem to map the drive nor actually connect to see the contents.

In the WD webpage in my browser (Chrome) there’s the little button on the bottom right (IIRC) which is ‘view my files’ or something, this does nothing. Also if I click on the drive through Windows Explorer I can’t seem to load it up.

Does anyone have any suggestions? Am I being stupid and missing something simple?

I had a read through the threads here but can’t see anything obvious.


Forgot to say, the WDLink software (called something like that - for auto mapping the drive) can see the drive in the upper window, and I can select it, but then the ‘map drive’ button at the bottom is greyed out.

WD Smartware says “no writable WD Smartware partition found”, but finds the drive itself

Bump :slight_smile:

Changed the drive over today at the shop, same issue - so have ruled out a faulty drive.