MyBook Live unable to connect after rebuild script

Hey all,

So Ive had issues with my WD MyBook Live white edition network drive, I couldnt access it at all so I did a google and found this thread.

I get up to this bit on the guide. I cant access my dashboard for my network drive to enable ssh and create the swap partition, can anyone please help me :sleepy:

Put the drive back in the enclosure and now we need to fix the SWAP partition

This is easy to fix once you boot the drive after the debrick

SSH in using PuTTY or Terminal

Username root

Password welc0me

MyBookLive:~# mkswap /dev/sda3Setting up swapspace version 1, size = 500672 KiBLABEL=, UUID=c3bc3a15-4b8d-407b-b897-956cc956e138MyBookLive:~# rebootBroadcast message from root@MyBookLive (pts/0) (Sun Mar 10 14:09:02 2013):The system is going down for reboot NOW!MyBookLive:~#

The drive will now reboot

SSH in again and verify SWAP is working

Now after the script was done I plugged the drive back into the router and its still not working. I got up to the step of rebuilding the swap partition but I cant ssh into the network drive because I dont have an IP address for my drive.

Im not sure what to do from here can anyone please help Ive posted on multiple forums but no one seems to know whats happening.

Thanks
Daninozz

There is no My Book Live white edition. You probably have a My Book World and this script was probably written for the My Book Live. You might want to check the forums for My Book World scripts.

Well sorry to tell you but there is, anyway once I’ve ran the script should I be able to get the hard drive to work? Because it doesn’t even pick up as a hard drive after the script. However if I reformat the drive as NTFS It works perfectly fine. Its only when I try and use the script where I get issues.

Perhaps if you provide the model number of the drive you have, it would remove any confusion as to what device you are talking about. If it is a My Book Live single drive unit and you pulled the drive and formatted it to NTFS, it would have wiped the included OS on the drive and the enclosure does not have the ability to recover the OS to the formatted drive since the OS is partially written to the drive during assembly.

Ah ok that makes sense I have two other network drives that are MyBook Live models.

Now that I know this is the case do you know of any scripts for the my book world to fix to the drive?

That model number is for a My Book World drive, not a My Book Live. They are two different products.

Ah OK that makes sense the reason I got confused was because I have another two network drives except they are black.

Anyway do you know of any scipts I could use to fix the drive?

No, sorry, but as I suggested in the initial reply, you can browse the My Book World forums to see if anyone has posted there.

Ok no worries thanks

Update found a different version of firmware ISO flashed and working perfectly fine.

I am curious as to why its not showing up when I click on network like my other drives do my MybookLive and my storage drive. Yet I can map my drive and make folder shares.

Not sure why this is?

Problem solved the network drive wasn’t on the right workgroup.