MyBook Live not working with Windows 7 (64-bit) laptop while connected wireless


WD MyBook Live (2 TB) is connected to our router as a NAS. It works with Windows XP computers  and with Windows 7 computers connected via cable just fine. The thing is, it just won’t work with the Win 7 Home Premium (x64) laptops, while they are connected wireless. MyBook works with XP machines no matter how they are connected to the router…

What does it mean, that it does not work?

I can (talking about Win 7 and wireless connection from now on) connect the HDD as a Network Storage and access folders till I get to some final folder or a folder that contains some files. Then the connection freezes and I can’t download anything from the HDD, nor can I upload anything there at anytime. The bar simply stays at 0%.

Another thing is, that I can ping the HDD and it responds. However, when I enter the IP address or “mybooklive” after HTTP:// in a browser, the page just starts loading but nothing ever shows up (with a cable, this all works fine). Just can’t connect to it.

I checked the router’s log and it permits all the actions from the laptops and from the HDD, thus I believe the problem is either the Windows or the HDD configuration.

I tried changing virtually every single option (static / dynamic address of the HDD, Windows sharing settings, firewall, username and password of the HDD), but nothing helped (even tried changing some LAN authentification method from NTVLM2 to some “older” option) and while nothing helped here, it worked while being connected via ethernet cable all the time (but I don’t want to be connected via cable, of course).

Plus it is weird that the mean of connection makes such a difference - probably some authentification or certificate issue?

Can you please help me out a bit? I’d be very grateful for any suggestions or tips… I appreciate it :slight_smile:

mykem, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support