MyBook Live not responding in any way


I’ve been on vacation for some weeks and had my Mybook Live from 2010 turned off. When I turned it back on, it’s not working properly.

At first, the web UI login page showed up but my password didn’t work. Also I couldnt connect to it in Finder (yes, I’m on a Mac).

So I tried restarting it again and now its even worse…

-The device is blinking with a green light (manual says that means it’s busy with a network transfer).

-Web UI doesnt respond. However, if I enter the IP address it redirects me to [IP address]/UI , meaning that at least I’ve got the right IP address.

-The network drive shows up in Finder but when I click it it just says “Connection failed”.

I’ve tried restarting it by switching off the power and also to reset it with the tiny button on the back. None of which had made any difference.

I’ve also tried to SSH to it but it seems like the SSH is offline.

Anyone got an idea on what to do next?

My warranty has expired so if there’s no way to fix it I’ll probably try replacing the internal hdd, but I really wanna try to fix it on a software level first…

Since by IP works and you have a blinking green light,  it means MBL is fine, nothing wrong with it. 

Did you have SSH set before? Or just make sure it is active.

You probably got a new IP after power up, your DNS is acting up. It could be cause it is cache, not updated yet, might have to flushdns, etc etc,

Try the following:

Finder/Go/Connect to server. Try it be entering the IP address.

If the above works, give it some time, and DNS/access by name might be fine after a while. 

To avoid it in the future, you could try one of the following:

  • Set a static IP

  • Make a DHCP reservation for MBL on your DHCP servers.

I had it turned off for a week, turned it back on now.

Getting a blinking green light which eventually turns to a solid green light.

However, I’m not getting any response network wise and my router is not showing the MBL in the list of active devices. 

I’ve tried restarting it, same thing. I’ve also tried reseting it with a pin again but the MBL doesnt respond to the reset button any more.

To answer your question Shabuboy: Yes I’ve had it set to SSH before, but SSH didn’t work last time I tried (nor this time).

It is very likely that the MBL did an auto firmware update and corrupted something in teh process. This seems to have happened to many users for the last two firmware updates.  Since you cannot get it to restore with the button on the rear, then you should try to debrick it with a debricking script. There is one posted on this forum.  It works very well and you will not lose you data.

What type of dock or connector is needed to plugin the internal drive to my laptop?

If I need to replace the drive, which kind of harddrive do I need to buy? (i.e. eSata, sata2 etc?)