Mybook Live doesn't install, cant be detected, UI not working, MBL is slow

I bought a MBL 2TB last year. I have never been able to install it. I though I’d give it a go now but NOTHING seems to be working with this unit.

I am on a MacBook Pro.

I CAN access the MBL from a browser, but I am not allowed to do anything, presumably I’m only a guest or similar. Every attempt to create a user or similar is met by an error “you are not authorized to do freaking **bleep** on this thing…”. What’s weird is that there’s no login screen anywhere, so even if I wanted to I cant use the admin passowrd to make things easier.

The unit is not discovered when I run the installer. I CAN connect to the drive both as the admin and a guest if I connect to it via SMB.

Iam getting VERY close to recording a video as I bash this piece of **bleep** to molecules and post it on youtube to serve as a warning to others.

This post is a request for the final chance WD will ever get to save a customer, otherwise they can kiss any future business goodbye.

So you’re saying that when you login to the webpage, it goes immediately to the configuration pages instead of going to the login screen?

If that’s the case, try:

  • Clearing the cookies
  • Clearing the cache
  • Try a different browser

Been there, done that. Tried Safari and FF, same result on both. Washed cookies and cache on both of them.

What happens when you click the LOGOUT icon?

I have tried a second laptop as well, this one has NEVER been used to access UI. Same result again. I’m beginning to believe that MBL is completely incapable of doing anything useful at all…

Maybe I can use it as landfill, bahaha…what a piece of junk!!!

I posted right as you did, so you may not have seen the post above yours.

In addition, right after you bring up the web UI and before you do anything else, can you take a screenshot and post it to some place like imageshack?   (WD requires moderator approval for images pasted into the thread, and we probably wouldnt’ see it until Monday.)

There is no logout ICON.

You can check out the screenshot here:


Did you set up the password yet?

There’s a hotlink at the top that indicates that you haven’t.


I’m not allowed to enter a password…**bleep** al’a Western Digital!


Why does your browser say “TipconContent” in the address bar?   What is that?

That’s the name of my MBL

Ah, Ok…

Well, I’m out of ideas…  When I googled that error code, there are people encountering the same issue, but most of the posts are fairly old.

There’s a few recent ones on this forum, though.

It looks like people have had varying degrees of success with re-installing the firmware via SSH, but if nothing else works, it should still be covered under warranty…  Call WD and request a replacement.

When you receive the RMA, before you do ANYTHING to the drive short of configuring it to work on your network, update it to the most recent firmware.

Sorry I couldn’t be of more help…