Mybook live disappeared from network, but Tonky still working!

Hi All,

My book live has “disappeared” from our network:

I can see it doing an arp -a.
I get a response from pinging it
If I point a web browser at the ip address ( I get a Twonky server window & can see and play audio files, etc.

Using Windows 7:
I can no longer see it in Explorer
WD smart manager can’t find it

I have tried on several PCs - same response. Tried with a different router - same - tried direct to PC connection - same!

My guess is that there must be something wrong with the fileserver in the unit, but it doesn’t make sense that Twonky still works!

Have tried the reset button - no change
Unfortunately, the LEDs on the front of the unit stopped working about 6 months after I bought it, so I can’t get any feedback from them. It has been running perfectly for about 3 years or so.

The drive seems to spin up and read as you would expect.

Any ideas for further troubleshooting gratefully accepted!

I would suspect Windows rather than your MBL. I have Win10 and don’t remember the Win7 details. With Win10, switching routers will turn off “Make this PC discoverable” and you mentioned that during diagnosis you switched routers.

Check to make sure you still have the various network sharing values turned on and (if this is applicable to Win7) that your network “current profile” is “private”.

Also check to make sure NetBIOS over TCP is still enabled. Odd things can disable it.