MyBook Live 3TB: Remote & Web Access Problem (31652 &31602)


I have been trying to enable remote & web access on my MyBookLive 3TB, but to no avail


  1. Unable to generate remote access code (Error# 31652)

  2. Unable to generate web access account/password (Error# 31602)

I have performed following actions:

  1. Checked product registration

  2. Checked network connectivity; Drive is connected to the router, checking for updates and sending out email alerts

  3. Disabled/Enabled Remote Access option

Looking for ideas about what’s going wrong!


PS: What’s up with WD Email Support? I tried to create a support ticket 4 times, everytime there was an ‘internal server error’. This is the third time that I’m typing this message!

Be sure to have the latest firmware version installed, try pressing the reset button on the back of the MBL for 4 seconds. If that still doesn’t help, do a factory restore from the dashboard.

With the email support, I noticed that even though you see the error message, when you go back to the portal the case number is created. :confounded:

Has this problem already been solved?

I have exaclty the same issues:

  • can’t create any remote access code anymore (worked in the very beginning), always error 31652

  • remote access activated and connected

  • internet accedd “good” (as the console says)

  • latest firmware installed (02.32.05-046)

thx, Mike


Another one with the same issues. Anyone got any furhter with this yet?

  • Registering the drive gets me a 31574 - Error registering device: Internal server error.

  • Asking for a mobile access code gets me a 31655 Error generating code for your mobile device:You don’t have permission to access a resource. PLease try again.

  • Asking for a web access account gets me a 31602  - The web access account you asked for could not be created. Ensure that you do not have any network connectivity issues and try again.

  • I have the latest firmware MyBookLive 02.32.05-046 : Core F/W

  • Internet Access is showing as Good

  • I have a fixed IP address

  • I get the same errors with the firewall turned off.

Does anyone have this facility working?


Plenty of posts about remote access not working! It seems to be an issue with some but not all users. I also suffer the same issue in the latest firmware update. Completing and RMA or reset will not fix the issue for me nor will openning ports on the router!