Mybook Live 2TB-Connection Failed

Hi,

I had problems connecting to my interrnet recently and I had to switch off the router. But it led to a big problem when I tried to connect to mybook live.:angry:

The status of the lights are:

  • the front LED light is solid green and blinks once in a while
  • at the back, the top light is blinking in green and the bottom light is solid green

Tried troubleshooting:

  • the connection directly via ethernet to the router is working fine and this is the same ethernet port on the router that is connected to mybook live. So the physical connection seems to be working fine.
  • to access mybook live via http://mybooklive.local and my customised name for the Mybook live 

Outcome:

  • When I click on ‘Connect as’ the message was 'Connection failed. The server “my customised name” may not exist or it is unavailable at this time. Check the server name or IP address, check your nentwork connection, and then try again."

Would appreciate if you could provide advice. Thank you.

Are you on a Mac?

See if the same things happens if you map the drive