MyBook Home 320gb spontaneously disconnects/reconnects


#1

MyBook Home 320gb suddenly, with no apparent cause, disconnects itself.  Windows Explorer says it’s gone. Disk Management says it’s gone. Then It will re-appear seconds later, minutes later or sometimes, overnight. When it disconnects, the light goes out on the drive, then comes back on when the drive restarts.

Actually, it just happened as I was typing the sentences above. I heard the “bee-doop” sound and it was gone. Seconds later, “doink”, it re-appeared.

I have swapped USB cords with another external hard drive  with absolutely no difference. I’ve plugged it directly into a wall outlet, no difference. When it’s connected, Disk Management says Healthy (active).

The other external drive has never hiccupped in the six months I’ve had it. The MyBook Home drive has been doing this on an increasing basis over the last month or so. Now it’s happening several times a day, sometimes going AWOL overnight. Sometimes it  will disappear in the middle of a file transfer and I have to start over.

This is scaring the heck out of me. I feel that I cannot trust this drive at all.


#2

Hi there, I have other ideas, but I will need your help on this, try a different port on the same computer or test the drive on a diferent computer and let me know the outcome.


#3

 I have tried different ports and different cables but I always get the same result. I unplugged the cable from my other external drive which works fine and plugged it into the WD and got the same result. I plugged the cable from the WD into the other drive and it ran fine. I’ll try the drive on my wife’s laptop when she gets home this evening.


#4

The drive ran intermittently for several hours this afternoon and evening.  I was finally able to move all my files to other drives which was a big relief. I downloaded the Data Lifeguard Diagnostic and ran the Quick Test. It passed. I downloaded and installed the Firmware  Update.  Then I tried the drive on my wife’s laptop. It seemed to worked fine for the few minutes I had it connected.

Then when I plugged it back into my machine again it connected-disconnected-connected several times within about five minutes. When it seemed stable I ran the extended test. The test closed abruptly within two minutes with a dialog box that said “FAIL - too many bad sectors detected”.

Fortunately, I still have the ability to return it under warranty, which is what I intend to do. Thanks very much for your help.