MyBook Folders appear, but try to open says folder empty


I am a computer novice so please bear with me. I purchased a 750gb My Book Essential Edition 2.0 a couple of years ago and it worked fine on my HP desktop with Windows Vista. I now have a new HP laptop with WIndows 7. The drive appears i my computer, I can open the drive and see all of my folders, but when I click on a folder (family pictures for example) it says the folder is empty. When I check the properties of the folders, it shows I have files in that folder, they just don’t appear when I attempt to open the folder.

I read on a forum to try going into disk management and change the drive letter, which I did, and it continues to do the same thing.

Any ideas?

Try deleting the driver in Device Manager disconnect safely and reboot PC. Then reconnect drive. That should load a new driver that may help.


Thanks Joe…tried it, and it still is saying the folders are empty even though the folder properties are showing there are files in the folders.

I think I resolved my issue…I checked each folder after opening the external drive. I looked at the properties and it showed they were “read-only”. So I unchecked that for each file and it appears that all is there.

1 Like

Thanks for sharing.