MyBook Essentials not being recognized on another computer

 I’ve owned a MyBook for 1 Year now (I think) and haven’t had much of an issue with it. It worked well on my other computer, which was a Windows 7 Home Premium 32 Bit, and worked perfect with it. Now it won’t work with my new one which is a Windows 7 Ultimate 64 Bit. I’ve tried to change the Driver Letters but it’s not there (the Drive, the Smartware is though) and updated the software, etc. The Driver is on, the cord is fine, apart from a bit of dust it’s never been damaged. 


 Deimos (Old One):

 * Windows 7 HP

 ** 32 Bit OS

 Phobos (New One):

 * Windows 7 Ultimate

 ** 64 Bit OS


 * My Book Essentials 2 TB

 Edit: The Drive appears in the Disk Management window as a Mass Storage, but when I try to change the letter, it won’t let me because it has to be refreshed. I refresh, It’s still unable to be changed. It also works well with my Windows 7 Starter 32 Bit Laptop with no errors either. Is it because the Drive doesn’t support 64 bit OS?

nah, the drive should work with both computers

try a different port and update the drivers

 Already updated all possible drivers on both the Drive and Computer aswell as use other ports. Still nothing.

Most probably this is a driver problem on your W7 64bits.

I would try to :

-remove the drive

-delete the driver on the new PC


-Install drivers 

-re-plug the drive

Alternatively you could select the drive in computer management and choose to update the driver with the “have disk” option (not by downloading the most recent driver from the web)

Also if it appears in the Disk Management window as a Mass Storage, doesn’t it have a drive letter already?

A snapshot of the window would help.

 I did both methods that you suggested, didn’t work. And the Drive is still having an issue with the whole Driver Situation.