Mybook essentials doesn't work

whenever i plug the external hard drive in the usb, windows tries to install the drivers but it fails to do so. i have tried everything, checking disk managment the drive is not recognized. its only recognized is device manager as a “disk drive” but i don’t have access to it. in smartware, it tells me its locked but i never set a password so i have no way of unlocking it except updating the firmware which gives me an error. are there any solutions for this, i don’t care about erasing the data. just want the drive to work properly.

Did you try different USB ports or a diferent USB cable less that 18"? Make sure you’re not plugging into a hub. Try moving power supply to a different receptacle not in a power strip.


tried that too. still no luck. i’m guessing the hard drive might be fried.

What OS are you using and did you try this drive on a different PC? It could be a problem with the bridge board. Probably contacting WD about RMA is probably the only thing left.