MyBook Essentials 2.0 1TB Not recognised on desktop but is on Laptop

So it has been working on and off recently, and it works on my laptop

So due to it not being recognized I tried getting the driver to download but it doesnt load properly see the images below. If there is a direct link on another website that would be useful. I am running Windows 7 64Bit. And Im assuming that my EHD is slightly outdated and probably discontinued had it a good 3/4 years.

However it is recognised on my Windows 7 laptop which proves it is a driver issue but i cant get the driver :frowning:

Image 1) When loading “WDSetup.exe”  tried running as administrator and normally. In compatibility mode for windows xp/vista. Still comes up the same. I got it from the WD website aswell.   Obviously not displayed properly/

Image 2) The files that were downloaded.

Image 3) What happens when I click the button I think is install. 

So obviously there is no Setup.exe in the files downloaded except in the Backup and Sync software folders.  So basically I would like the full setup files to be downloaded.