MyBook Essential very very very slow


I plugged the drive this morning and tried to transfert a 1.5 Go file.
The transfert hang-on the PC (Vista 32) and I had to reboot it.

When I plug the drive now, all is very very slow. I can see the drive into the drive list but when I want to browse into it takes some minutes to see a folder content.

I didn’t try to transfert any files yet, but I can imagine it is impossible.
What could be the problem ?
How can I resolve it ?

Thank you…

Did you try another port? Try one on the back without a hub and see if that helps.


I tried on another port : same thing.

The drive is not recognized when I plug it.
I have to wait 1 or 2 minutes to be recognized.
It is the same thing when I want to transfert a file.

I tried with a small file (4 Mb) it works but very very slowly (~10 Kb/s)

The problem is that the smart and quick tester failed from the WmartWare.

What can I do ?

I have a VERY similar problem on a 2Tb MBE bought last March. All actions taken are geologically slow. Mountains erode away faster. I think this is a WD quality issue. If tech. sup. brushes me off, I’m done with WD products.

Most probably your drive may have a faulty controller. To verify this, download WD DLG form here…

And run both quick and standard test. If any one of tests gives you an error report, you have no other option but to replace the drive. If both tests pass, you may need to upgrade drive firmware.

I have an error for the quick test :

status code : 4
failure checkpoint : 96

And two many read sectors for the standard test.

So I’ll change my hard drive.

It is still under warranty but I have all my data that I want to backup…

I don’t know why this drive failed…

It is the first time I have a HD failed and it is the first time I buy a WD drive.

I don’t think I’ll buy another WD, they are too “delicate”.

Anyway, thank you for your help.

Read this post. Especially on HDD Regenerator section. (Non destructive method) Lets see how it works for you.