MYBOOK essential now shows up as the CD drive! it registers as empty!


Today the plug got knocked out of my drive and i ‘think’ it ‘may’ have been in use.

the drive now doesnt register  when i plug it in. after for wiggling about etc it began to show up - but it was showing as the CD drive - which means all attempts to access it and read it dont work, because it thinks its an empty cd tray.

it sometimes shows up in the ‘eject software’ bit - but wont diconnect, it says its still in use - but its not.

it also shows up with its full name in various other places on the machine, so it knows its there .

the light is on and its making a gentle humming and whirring noise - no clicks etc.

i am trying various things, software etc to scan it etc, but not having much luck.

i have tried another usb lead but no change.

i checked on the drive manager and its showing that is not initialised, so i tried to do that but it wouldnt allow it - it said the drive is write protected.

it is also show as RAW,

This is the 3rd WD drive ive had that has gone wrong, with very little use - this one was a replacement and i have only actually used it about 10 times -  they are terrible terrible drives

i do not want to take it apart really - it is still in warranty. but i want the data.

how can this just stop working? it is set to where you do not have to eject the drive to disconnect it - surely there are processes in place to stop loss of data in these circumstances?

any ideas what i can do?

i had only just installed the software too, about half an hour earlier - could that be the problem?

i have put a password on it too - will this stop me having accessing it with recover software?

i have been through all the posts on one thread on here, from about 2 years ago, and tried some of the ideas, but none worked.

many thanks

The drive is probably corrupt. TestDisk or EaseUS Data Partition Wizzard  If they don’t work there is a last ditch thing that might fix it.