MyBook Essential I have caused myself a load of problem can any one help

Hi, I hope this query posting is not too long to get a response, as I am in real need for advice and guidance.

I have WD My Book Essential which I got new in mid August and I would be grateful for any advice on 3 issues.

  1. When I installed my new My Book Essential External Hard Drive and all went well until I followed instructions to update / upgrade the soft ware. I was able to download the file WD Universal Firmware Updater for Windows to my computer when I try to open - double clicking on WDFirmwareUpdater.exe I get the message “The application has encountered an unexpected problem and is now exiting”. I have tried downloading it several times with the same effect.

I was able on first attempt to download and execute WDSmartWare_Software_Upgrader_for_windows and WDSES Driver.

This has happened very occasionally to me before, when opening up a programme, PDF files or HTML documents. Normally I do not get any problems opening up any of these.

WD technical support suggested I tried uploading via a different computer and that worked and I do have one suggestion from Windows Answers.

  1. When I switch on the computer for the first time each day everything works well, but if the computer goes into sleep mode when I re activate My Book does not respond
    The light at the front appears dimmer and smaller and no longer flashes.
    The WD Quick Icon only states SmartWare and does not show anything about the hard drive.
    If I click the WDSmartWare icon in my start menu the normal screen is shown but only with my internal hard drive and files is shown. The WD hard drive is missing.
    If I click my computer some times the WD hard drive is shown and at other times it is missing.
    Re booting does nothing to resolve the issue.

I go through the process of closing down the WD hard drive as per instruction manual but the front light never goes out.
If I unplug the hard drive from the mains socket and then plug it back in, it starts working normally.

I have not noticed this problem if I do not stop using my computer so it does not go into sleep mode.

I have rectified this by deactivating the sleep mode, but I was wondering if there was another way around this so that I can reactivate sleep mode.

  1. This problem is most probably of my own making in that when Paretologic Health Check ran for the first time after I first installed My Book I did not check what it wanted to fix before I pressed the fix all button. Since then I have stopped it from doing anything  that identifies a WD program, registry report etc.

After the first health check My Book did not work at all. I went through a number of routines i.e… rebooting, disconnecting and reconnecting the hard drive with no success. I then reinstalled SmartWare from MyBook hard drive and all went well until I tried updating WDSmartWare Everything is fine until the last part i.e… after pressing the key to update, after pressing the accept End User Licence Agreement. It starts to update and then suddenly stops with a message "Installation unsuccessful (Code 1603) Please try again or contact WD for assistance

The WD technical services suggested that I un-install the WD SmartWare I had on my computer from the hard drive itself and the download and run the updated version.

When I went into Control Panel - un-install to my surprise there were two WD SmartWare programs one dated the day I first installed the program and the other dated the day when I reinstalled the program. In my ignorance I thought the reinstall would go through the initial install and not set itself up as an independent program.

I tried un-installing the older of the two programs but it would not un-install it kept coming up with “There is a problem with this Windows Installer package. A program run as part of the set up did not finish as expected. Contact your support personnel or package vendor.”

The newer program un-installed normally.

I then tried again to un-install the older program with the same result as the first time. I did this several time with no luck so I tried installing the update but it kept coming up with the message saying no update was necessary, so would not proceed. I then tried regedit and Health Check again, to try and get rid of all references to SmartWare on my computer, but still the program would not un-install or delete. The same messages kept coming up what ever I did.

The WD hard drive did not work.

I then reinstalled the SmartWare from the hard drive and it started to work normally but it told me I needed to update the soft ware and again the same error message and code 1603 came up. According to home page of the soft ware the version I have is and I get an update available message.

Has anyone got any ideas as to how I can get rid of the older installation?

My computer:

Constructed and configured just over a year ago by CCL

Asus M4N78-AM motherboard

AMD Phenom II X4 945 processor

4GB Ram

Primary hard disk 1GB

Back up Disk WD My Book Essential 2GB

USB 3 Expansion Card by Transcend

Other USB are all USB 2 part of the motherboard

Windows 7 Home Premium 64 bit + Service Pack 1

Office Home and Student 2007

Kaspersky Internet Security 11.01.400 

Paretologic PC Health Check

Windows Live Mail 2011

Windows Internet Explorer 9.0.8112.16421 update version 9.0.2 

I update the above both as an automatic process and again check for updates manually once a month

With the exception of the secrity programs which are configured not to alter any of the basic stuff without asking first all setting are set at default or have not been entered into from the day program was installed.   Pop up blocker is turned on

Thank you for any advice or help you may be able to give.:cry:

A lot of people are having the same problem, so far the only thing to do is to find a way to clean  the registy to kill the remaining fies, Ccleaner seemed to do the trick for some. However, if I were you I’d try to contact WD and exmplain that SkyNet (Smartware) is refusing to be uninstalled… Since this is something specific they may give some suggestions as well.

1 Like

Thank you, I will talk to WD