MyBook Essential 3.0 2TB Issue [Not recognized]

Hey Guys,
I finally upgraded my Asus P6T Deluxe with a Asus U3S6 PCIE Card to have USB 3.0 on my computer.(yaaaay)
My problem is, that my drive, which I already used 1 year on USB 2.0, is not beeing recognized by my new USB 3.0 ports.
Other USB 3.0 drives and even older 2.0 ones work fine and got no problems with them.

What I already tried:
-CMOS Reset Bios
-Firmwareupdate WD 1130
-BIOS Update Mainboard
-Deleting old drivers for all OnBoard USB and ExtensionCard and get new ones
-Tried like 10 different Drivers for the Asus U3S6(NEC/Renesas Chipset)
-Firmwareupdate Asus U3S6
-Tried connecting MyBook to other Computers, but had not the chance to try it on another 3.0 port
-Succesfully connected a Seagate USB 3.0 drive to the Asus U3S6 Card

I don’t know what to do next… I can’t RMA or format my drive, because at the moment I don’t have enough free space to back it up to my computer. I only have a 150GB Velociraptor drive and the MyBook always functioned as a data storage for EVERYTHING else then Windows and programs.

I appreciate your help,

I think you covered mostly all possible troubleshoot, I recommend you to contact WD and ask your case to be handled by their advanced support.

1 Like

At first, thanks for your advice and I already started a ticket now.

IF there should be an other solution than sending the device in RMA, I will let you know.