Mybook Essential 2gb software freezing on unlock of password

Ok so I am not a noob at computers, haven’t done anything outside of what is allowed by the software or by my computer.

I got my drive about 4 months ago, and recently decided ( probably stupidly) to apply the password to same using the WD Smartware software that comes with the drive. Now for some reason the software freezes when trying to unlock the drive and goes to a non responsive state.

I have tried removing and re installing the HD on several occasions also tried installing on my laptop and the same thing happens. I have also (after reading through the forums on the WD site ) tried updating software, downloaded the latest versions of the software. Still no joy. Anyone got any suggestions as to what I might try next ???



Hi there

Have you tried the drive on another computer? sometimes the problem may not be on software but on the os on that particular computer. I would suggest to try the drive on another computer to see if you have the same problem, if the drive ( or software in this case ) doesnt do the same on another computer, then you can discard the issue on the software and try to fix the os.-

Same drive (myBook Essential 2 TB with Smartware, Encryption) and same problem :cry:

Once plugged in, Virtual CD (VCD) mounts as usual, the Unlock-utility comes up and reports ‘your drive is now unlocked’  and the under XP the system grinds to a halt, hangs or call it unresponsive, unplug the drive and Windows XP springs back to live instantly.

Under Vista and W7 the drive partition is not recognized or mounted and at least under W7 you keep getting a periodic error message.

Problems with drive began after adding a new drive (MyBook Essential USB 3.0) incl. the Smartware Package and carry out the recommended firmware update on the ‘old’ MyBook.

Simply co-incidence or ?

Contacted WD support and received almost instantly an email back - from a real person addressing my described problem !  -  and with it came their explicit permission to open up the case and try to salvage / recover my files via a  direct SATA connection prior to exchanging the drive under warranty.

Very professional indeed, thanks for that and much appreciated.

Unfortunately as described in many other postings, using a direct SATA connection for the drive, the hardware encryption chip located on the small USB connector board, is out of the loop.

Without this chip  -regardless if encryption is enabled or not via password- all you are able to read out is garbeled, encryped data.

So the hardware encrytion is always active, allowing access to the drive is where your password comes in.

To make matters worse -on the other hand also very save- the encryption chip is paired with the drive unit and can not not be simply replaced with a new one.

Nevertheless what I go out of it is that the disk / drive unit  itself appears to be in good working order, so defect USB connector board seems to be the problem.

So re-assemled unit back together.

Due to nature of data, Professional Data Recovery Service was not really an option for me so I tried various tools I could find on the net.

I got lucky and managed to get access to my files using a free software tool “TestDisk 6.12”

Homepage Link: \wiki\TestDisk_Download

Most important steps - details on request:

-If drive is locked by password, the folllowing only works if the units Virtual CD emulation with the Unlock Utility is still available and mounted as usual

-Disable or uninstall the WD-Smartware (Stop Services related to WD and disable WD related startup entries, reboot if necessary)

-Plugin the drive via USB but in case of active Autoplay do not confirm your password in the Unlock utility on the virtual CD Drive just yet

-Start the Testdisk_win utility (as administrator)


-next screen select the media - with 1999 GB the Mybook one is easy to spot :wink: and confirm

-Switch to unlock utility from CD and execute password - drive is unlocked confirmation and exit

-switch back and after waiting for like 5 seconds choose partition type EFI GPT - this prevents Windows from trying to mount (and block access) to the partition


-MS Data or similar should pop up instantly and you can stop further discovery by confirming the already marked with enter

-you are presented with a green highlighted partition - start sector 2048, etc… by enter

-choose confirm enter

-your are back on previuos screen - chosse file system uitilities, next screen and after a few seconds the miracle has happened and you are presented with a DIR List of your drive

-Navigate through the directories and highlight / copy either single files or complete directories as indicated by on screen instructions

-Recovery / copy speed is with 0.3 to 6 MB/s rather slow so I chose first the most important files just in case…

-well what do you know - hooked it up to an old laptop and left it running - after almost 2 weeks I have recovered 99% of my files, 5 movie files had a few damaged sectors but were copied nonetheless and quickly repaired

What can I say - great utility and worked perfect in my case.

Somehow this ingenious little tool manages to go where windows could not and 'tunnels" through the defective chip(s) directly  to the files.

 To reinstate original state, simply choose PC/Intel partition type and write it out. This reinstates the original NTFS header.

Right now I am wiping the disk via reformat and a direct SATA connection before exchanging it against a new one.

Many thanks again to the WD support for their quick and professional response.

Should however consider to either locate the encryption chip somewhere else or have it exchangeable.

Based on the many postings this little board seems to fail all to often.