Mybook essential 2 TB USB 3.0 not starting up

Yesterday the drive did not shut down with the computer automatically for the first time, so I pressed the power button at the back until the drive stopped. Today it won’t startup again. What’s wrong? Please help!


I would recommend you to press and hold the power button in the back of the unit for a few seconds, try a different power cord and also connecting the drive to a different USB port.

Pressing and holding the power button did not solve anything, also other USB ports and connecting to another computer did not work out. I have no additional power cord for this device.

I think the power button only works if you have the Smartware installed.


WD smartware was installed

I assume you already tried disconnecting the Mybook completely, then power-cycling the machine.

You could also try connecting the MyBook to a different USB port on the same machine, but you probably thought of that too.

Maybe try a different computer, if you have one.  There’s a small chance that there is something wrong with the particular USB port/USB controller on the machine you used.

If none of that works, I’d say you have a dead MyBook.  Hope you had another backup, or didn’t yet put anything essential on the drive.

I am having the same issue.

this morning I tried accessing the my book essential and it didnt work, I tried disconnected restarting , chaning usb ports pcs, nothing worked out. the hard drive doesnt show up in the computer at all, even in the device manager, I dont know what to do, when I press the power bottom or reconnect the power cable I hear sort of clicking or seperate spining sound.

then after 2 mins it stops.

I have contacted WD and explained the issue for them, I have also contacted the distributor in my region to request a repair or a replacment since I have only had this device for acouple of months and its already acting up. I cant think of anything up normal I have done that caused this problem apart of its defective, cuz  if its a customer using problem it would at least appear in the device manager, but it`s dead. and am really upset cuz of the important data and backups stored inside it. :frowning:

Ouch.  It appears that WD is really, really horrible at building drive enclosures.

Their drives seem pretty solid, at least.  I’ve been running an older 320 GB model (WD3200JD) continually since 2007, and SMART monitoring still says it’s A-OK. Hoping that trend continues with the 3 TB (WD30EZRX) I bought recently.

I had my computer on the entire day (importing a large database), and fore some strange reason, the white led was blinking! Got full access to the hard drive again. This is my second mybook, the first one was not recognized in explorer nor in disk management, so I brought it back. Still think I’ll bring it back, don’t trust this…

Your instincts are good, I wouldn’t trust it either.

I still need to get a third backup drive.  I may use a Western Digital hard drive inside, but I’m staying away from their external units.  Too many failures and too much complication (“smart” power button, automagic hardware encryption, weird micro-USB port).  I’ll just “roll my own” by purchasing the enclosure separately.