MyBook Essential 2 TB disconnecting after about 10 seconds


#1

For some reason, my external hard drive, a 2 TB MyBook Essential, has been automatically disconnecting after only a few seconds every time I try to connect it.  I am running on a MacBook Pro with Mac OS X 10.6.7.  It worked properly for about 2 and a half months, and is partitioned into two 1 TB partitions.  When connected, it used to display the first partition, and then a few seconds later the second partition would show up.  Now, the first partition shows up, then after a few seconds it says that the drive has been improperly disconnected (as if I had pulled the wire out) even though I have not disconnected anything.  The drive does not shut down, it simply remains on in an idle state (the light on it is on and solid).  After paying a nice chunk of change for this hard drive, I am not pleased with how quickly it seems to have decided to ■■■■ the bed.  Anyone have any suggestions or ideas on how to approach this issue?  Thanks in advance for any and all help.


#2

Hi there

have you tried using another usb cable? that could be the problem.-


#3

unfortunately the USB it came with is a USB 3.0, so it is the only one I have (it has that strange two part connector on the one end).  I called WD today and they are sending me one in a few days, so we will see if that is the issue when it arrives.  Since it does recognize it for a couple seconds I have a feeling the cable works, but it certainly is a possibility.


#4

I have a similar problem. i just partioned my 3TB and thru half way of backing up my files. the ■■■■■■ said i have improperly disconnected without disconnecting the bish. now my laptop doesn’t read my 3TB. does not pop up like it used to