MyBook Elite 2.0TB installation trouble

I have 3 MyBook Elite 2.0TB drives that I have had for about three years now.  Overall, I love them.  All three were successfully installed on a ten-year old PC running XP Pro SP3.  I acquired another PC a short while ago, a Dell Vostro PC that is seven years newer also running XP Pro SP3 and I am not having ANY success in the installation process.  When the Found New Hardware Wizard comes up the computer cannot locate the appropriate driver to complete the installation.  Before going further, I should state that I also have a Seagate 2.0TB external harddrive that is also not being recognized by this newer PC either.

The computer has 6 USB ports and other small USB devices like a flash drive are easily recognized; I’ve tried each of the ports on the front and back to ensure that it wasn’t a problem with one set of ports versus the other.  I consulted with the WD Knowledgebase on this and per their recommendation went so far as to load the SES drivers and SmartWare on the computer before attempting to proceed through another installation thinking I needed to point the Hardware Wizard to the drivers l just loaded.  Same result.

I called WD Support, received a top-notch willingness from the tech I talked with, but it appears I baffled them.  The only suggestion I was left with was to call Microsoft because the problem does not appear to be on WD’s side.  If there is anyone that can provide some insight as to what is going on, I would be appreciative for the assistance.  Thank you.



I wanted to follow up with some other things I’ve tried myself, unfortunately in vain.  Reviewing some other online responses for similiar problems, it was noted some of the other reasons why this wouldn’t work was because of a plug and play issue.  I have to go back and correct myself from what I stated above.  I attempted to plug in a flash drive and it would not install.

I went into the Computer Management section inside the Control Panel and noted that Plug & Play had been started, but also recognized that Universal Plug & Play was disabled.  I corrected this and enabled Universal.

Next, it was also mentioned something could be disabled on the BIOS side.  I went in and was surprised at what I found.  Incredibly enough the MyBook was showing up in the recognized boot sequence (as it was still connected at the time of reboot).  Then when I went back into Computer Management to see if it was reflected as a valid drive, perhaps just not initiallized, I didn’t see it at all.  So, this confuses me.

Anyway, I wanted to follow up with my own seemingly self-inflicting troubleshootig efforts but still appreciative for any other thoughts some forum members may have here.  Thanks again.


Have you tried updating your USB drivers and USB controlers? Make sure you are using a cable the same lenght that was supplied. Longer cables and hubs can cause problems.