MyBook Duo unable to update to firmware to version, and DLNA server very instable

Since noticing that there was a new firmware update, and reading on a few other posts that the latest firmware has helped with the issue I have been having with the built in DLNA server (it cuts out roughly once every 4 or mins, and only becomes accessible by a DLNA client again once the service is stopped and started through the control panel, which makes using it for viewing photos or watching videos impossible), I have been trying to update. It appears the update is only available via the internet update in the control panel for the MyBook Duo, but fails every time I try to run it, either claiming no internet access is available (not true), or simply failing after sitting at the updating screen for about 15 mins. Occasionally it goes a little further through the process but then just claims the package is invalid. Is there anything I can do to get the files for download and import them locally, or are WD able to fix the update process so I can run it successfully from the control panel? Right now my NAS drive is virtually unuseable for the purpose it was intended.

Thanks for your help in advance.

Hi bengallienne, welcome to the Community. Have you tried to rescan or rebuilt the database? Check page 113 of the manual for more information on this.


Thanks for replying. Are you referring to the DLNA server database? If so then yes, I have tried to rescan/rebuild that several times. It doesn’t seem to make the DLNA server any more stable.

Any other ideas?