MyBook Duo only recognized on older iMac - Help

Hey guy!
I have spent some time looking for answers on this but didn’t find anything that satisfied me, thus this post:

I have a WD MYBOOK Duo of 2x3To. One copies the other, thus only use 3To.

At first I had it connected to my TimeCapsule as a hard drive available to my few co-workers. But it stopped being recognized.

So I connected it directly to my iMac but it had trouble to recognize it. I mean that nothing was showing up and then it appeared.

Then, once i a while I have to reboot my computer as it slows down and each time it takes a lot to recognize it.

Yesterday, I rebookted my iMac and impossible to recognize it. I tried many things, plug, un plug, remove disks, etc. Nothing. I can’t even run the WD tools because it asks me to connect a WD hard drive. And then, a blinking red light starts and is on since then.

So I’m about to give up and decide to plug it on my wife’s iMac and it recognizes RIGHT AWAY!!! I remove Disk1 and recognizes Disk2. I remove Disk2 and it recognizes Disk1. It all 100% operational. The red light is still blinking.

I connect it to my iMac and no recognition. Her iMac is from early 2009, has OS Yosemite 10.10.5. Mine is from 2017 OS Mojave 10.14.4.

It’s my humble viewpoint that there is a firewire problem. Could it be that WD doesn’t upgrade the drivers? I purchased this WD MyBook Duo in 2016, new from the store and it’s right after the end of the warranty that the problems appeared…

Thanks for your help!

Hi, did you run first-aid repair on your WD drive?

No I couldn’t as it’s not recognized in mine. But connected to my wife’s and it says that Drive_1 has to be changed. I just purchased another one of same size and same number. I put it in the NAS and connected it to my iMac 2017. No detection.

I connected it to my wife’s iMac 2009 and detected immediately. I’m restauring Drive_1 and have access to all the data.

The problem is related to the conection between Mybook Duo and the iMac 2017.

Thanks for help

I installed the new disk_1 and copied the disk_2 in it as it was in RAID1 - mirror. The WD utilities say “Disk Sane”. I unplug it and plug it into my 2017 iMac. but it doesn’t appear anywhere. Is there a way to update the firmware or something. It’s a communication problem between the device and the iMac.

Thank you.

Now, this is insane… listen to this…

I slowly introduced the USB cable into the USB hole very slowly and it got recognized. I had tried in several USB ports before. So plug it S-L-OOOOOO-W-L-Y…