MyBook Duo does not mount automatically after being re-connected on macOS Big Sur

Hi everyone,

I have recently changed to the new Apple MacBook Pro M1 running on macOS Big Sur. Following this change, I face a problem with my MyBook Duo 20TB (2X10TB) that it cannot mount automatically once being re-connected. I have to unplug and replug the power cord all the time before re-plugging the USB-C to my MacBook. If not doing so, the unit is only recognised on the system information but does not mount or show up on the Disk Utility at all.

There is also another problem when the MacBook wakes up from sleeping, the WD Drive Utilities application also shows a warning “error in RAID configuration”. However, a couple of minutes later, the MyBook Duo spins up and works normally.

I have no problem with my previous system which is an Intel iMac running on macOS High Sierra.

Hope anyone have a solution for me to sort this inconvenient problem out.

1 Like

Did you face this error on your earlier macOS?

@DonaldKepler Nah. It worked normally with my Intel iMac running on macOS High Sierra.

Exactly the same problem here with Mac OS 11.6 Big Sur and a WD Duo Book 2x 8TB drive connected via USB 3.1. I have also a My Book Thunderbolt Duo connected and that has no issues when the computer goes into sleep.

1 Like

So what’s the answer? … I have been contacting WD on this issue for over a year now. My Book Duo 6tb works perfectly with High Sierra - after that nada. I also have a thunderbolt duo that does not have the reconnect issue. Come on WD give us a reason why? OR just inform customers that they cannot use theses devices with an OS later than High Sierra.

1 Like

Unfortunately, there is still no answer from WD. I tried my friend’s MyBook Thunderbolt Duo and it had no problem at all. There is no clue whether the problem comes from the FW or the software or the connection protocols.

Any news on this topic? Having the same issue on Mac OS Catalina, 10.15.7