MyBook broken?


I have an old external HDD from WD, i think it is a My Book, since it looks like a book, but has vertical light line on the front.

A while back, it stopped working, probably because it fell over (from normal position to his side). I figured it had something to do with the casing, or the usb port. Yesterday I thought i could fix it by removing it from the case and putting it an SATA connection in my desktop (i founded out i had another sata connector hooked up and ready to go) However, this still doesn’t fix it.

Now it says in device control there is an “ATA Device”, in the start-up it pauses on port-05 (i think that is where the HDD is), but eventually says port-05: No Device, and with the WD Data Lifeguard Diagnostic for Windows, it does show another HDD, but with a capacity of 0 M. TestDisk doesn’t show either of my HDD’s.

It’s an WD10EAVS and my primary HDD is an WD500AACS. I run on WIndows 7 32-bit.

If you need more info, I’ll be glad to give it.

Thanks in advance

P.S - Data on the drive (if there was any) is not important, so data loss is no problem. Getting the drive to work again is of more importances

Apparently there is phisical damage in the drive, as a last resort please try write zeros on the drive and if you are unable to perform this action unfortunately the drive is irrecoverable.

I already did that, was done immediatly because it sees 0 MB capacity. But he does it though. Atleast yesterday, today it won’t show up at all…

It didn’t drop really hard or something…

Is there a way to physically confirm if the drive is damaged? Warranty has already passed.