Mybook 4tb not found in disk management Win 10

So my drive recently crapped out on me a month ago, not sure why but it wasnt found in windows and i kept getting USB errors, device removed.

Thought the USB pcb went bad, so i bought an identical to replace and still wouldnt show its face to disk management.

I connected it up to my PC via SATA and used test disk to fix the partition to get my data off which went fine. I then did a full format on the disk NTFS and tried connecting it up externally via USB 3 with the SES driver and still same symptoms.

Next i tried deleting the volume created during the full format i did after connecting it up via SATA again. Now the full 4tb of space is allocated and my laptop or PC wont recognize it in disk management with USB 3.

I have two identical USB 3 PCB’s same model and encryption.

Any ideas please? Using latest windows 10 pro on UEFI. The drive is already converted to GPT as well.

Hi, there’s many reasons as to why an external hard drive is not being recognized by the computer. You can click on the link provided below from some troubleshooting steps.