MyBook 3TB stopped working on HP dv7 laptop Win7 64-bit Ultimate

Yesterday it just stopped working after a system reboot.  Had worked for a couple of weeks prior to.  Device Manager shows driver is up-to-date.  I had a MyBook 2TB drive plugged in to USB 2 at the same time as the 3TB on the USB3 (no hub) when the failure first occurred.  Had moved over 1TB of data without a hitch.  Now does not work on USB 2 nor on USB 3 (both ports tried) , and with or without the 2TB.

My system:  HP dv7 i7-2630QM 8 GB 2x750 GB Win7 Ultimate

On a whim I walked the 3TB over to my Dell WinXP laptop, plugged it in and everything seems to be fine (with a reboot required) - so not a cable issue or power adpator issue.   WinXP even shows it as a 3TB drive so – fingers crossed – I am rolling off what I don’t want to lose (or am I just lucky for a change?)

I have a second 3TB unopened here and am wondering if I should try that one on the HP.

Could this be a firmware issue?

Any suggestions?

Thanks also to member for reminding about simultaneous MyBooks.  I had to change unique IDs once on two simultaneous Passports.

I don’t have USB 3.0 but from posts I’ve seen in different places it seems to me that USB 3.0 was not well coordinated between MS and the hardware makers. There seem to be many conflicting things that cause problems in USB 3.0. If you reformat the 3T drive remember it uses GPT instead of MRB. Also use the WD format tool, it has a option so it will be useable on XP. If you format another way it probably won’t work on XP.