MyBook 3TB for Mac will not mount

I have a 3TB MyBook for Mac. Earlier today, fter my MacBook Pro was fully booted, I plugged in the external’s power supply, and then UDB cable. It mounted normally.

A few minutes later, I got an alert saying something like “Be sure to eject your drive before you unplug it or turn it off.” THE DRIVE HAD UNMOUNTED ITSELF. At first I thought that the power supply was in a bad plug, so I moved it. After trying multiple plugs, I tried to test it with WD Drive Utilities. The progress bar made it to 90%, and then it failed. No additional information.

Is there anything I can do?

One more detail. When I plug the power supply into the drive, the power indicator LED starts out as solid white. Once it has been going a minute or two, the LED starts blinking. When I start the shutdown for my computer, the LED goes solid again.

Are you plugged into a power strip? If so, try plugging it directly into the wall to make sure it’s getting enough power.

Yes, I did that. WD Drive Utilities knows that the external is there. Disk Repair cannot detect it.

When the light is blinking, does the drive show up in Disk Utilities?

The MyBook icon did appear at the top of the WD Drive Utilities window. It does not show up in Disk Repair. If I launch Disk Repair before plugging in the MyBook, Disk Repair opens normally. If I plug the MyBook in first, and then try to launch Disk Repair, Disk Repair will write all the border areas of the window, but none of the function buttons show up.

I restarted my MacBook Pro (OS 10.11.6) in Safe Bit mode, but it did not mount that way either. It did not shop in Disk Repair, and WD Utilities crashed in Safe mode.

It happened with my Thunderbolt Duo on Macbook Pro 10.11.6. Randomly ejected and then not mounted at all. Very frustrating.

Here’s my Post:

I solved it now, Restored my MBPr from Time Machine a couple of days back solved the problem. I suspect it caused by the SysUpdates from Mac Store.

Did you update anything from Mac Store recently?

The best way to check was to use other Mac if available. or a PC using Paragon HFS+ installed


I had updates to Safari and security in the past month, but I don’t think that’s it, since I have experienced these failures in the past.

Have you tried a different USB cable? Tried connecting to a different Mac?

No to both, but I will later today. Good idea. I have a zillion USB cables, most of them new, luckily.

I plugged the MyBook into another Mac. At first the LED turned to solid white, and then it began to blink after roughly a minute.

When I launched Disk Utility, the external drive DID appear in the list of devices. It was greyed out, and Disk Utility suggested that I run Disk First Aid.

And so I have questions.

  1. Is there ANY way for the First Aid process to damage the data on this external drive?
  2. Does it matter what OS is running on the other MacBook? It is older, and it’s running 10.7. Can that be harmful?
  • OS 10.7 is no longer supported for running our software, but the drive should be fine.
  • Running First Aid should not be a problem.
  • Also, I would check out this knowledge base article, below. It’s loaded with direction - more than I can give you.

Thanks, will do.

When I am connected to the older MacBook running OS 10.7, I can see the drive greyed out in Disk Utility. With the newer MacBook Pro running 10.11.6, I cannot see it at any time.

Thanks Bill, I will look at this.

So, now I have another kind of question.

Now the friend with this other MacBook is apprehensive that if I use her Disk Repair, my drive can cause some damage to her Mac. Is that really possible?

Unless something is really, really wrong with her Mac OS, I don’t think so. If she’s really scared to let you use her Disk Repair, you could take the drive to an Apple store and they should be able to do it for you.

So, she decided she wasn’t nervous after all. After hours & hours of “Preparing to…” I woke up to see that Disk Repair could not complete the process. Sorry, but I neglected to write down the Notification.

Next, I booted the E Disk on my MacBook Pro, and tried running Volume Structures. That examination completed, saying only that it had Passed. Afterward, the drive appeared on my desktop. I’m getting a new 3-gig on Tuesday (a small USD, not the big MyBook which the disk-recovery company described as delicate), but I am wondering how to deal with the MyBook drive in question.

After I clone it to the new drive, should I wipe it with a more-serious zeroing routine? How can I tell if there are any other underlying problems with it?