MyBook 3TB drive not working - please help me!

I purchased a 3TB MyBook drive a little over a year ago. I’ve had no problems since then.

I sat down at my computer about a half hour ago and tried to access the drive, and noticed it wasn’t listed under My Computer. After ensuring the USB and power cord were plugged in, I tried resetting the power and noticed that the light on the front of the MyBook wasn’t glowing. So, then I took the adapter out of the surge protector and tried plugging it into another outlet. At first, the light turned on, but it glowed steady without blinking, and I didn’t hear the drive spinning. Then, the light died.

I took it into another room and tried plugging it directly into the wall. Same thing happend: the light turned on, but nothing happened when I tried connecting it to my laptop. When I unplugged the power adapter and plugged it back into the same strip, it didn’t even turn on. I can’t even get the light to turn on anymore.

So, can anyone give me pointers here on what may be happening? Do I just need to buy a new adapter or is there something else faulty here?

Also, if for some reason this problem extends beyond simply replacing the adapter - will I be able to pop the drive out and plug it into another external hub, or is it true that WD encrypts data and I’m “s*** outta luck,” so to speak? 

Finally, as a worst case scenario: since this is still under the 2-year manufacturer warranty, how would I go about requesting a replacement drive, if that’s what it comes down to? (And I really hope not, because I have a lot of precious data on this drive that I don’t want to lose.)

ANY pointers whatsoever will be appreciated. This is the first time I’ve ever had a hard drive failure so I’m not sure whether to expect good or bad news. I’m hoping all it needs is a new power adapter, but I have no clue why it just randomly stopped working. It’s been sitting steady on my desk and was working fine earlier today.

I purchased a My Book Essentialls in January to keep backups of my laptop and all my tools i use for my work.

Whenever I move the laptop from the desk, I find it easier and safer to simply shutdown and disconnect everything (rediculous i know). So two weeks ago, I was returning my laptop to the desk and was going to let the WD software do back ups over the weekend. I decided to not shut it down and just reconnect everything (Like you can do with USB), instead, I reconnected everything and began setting up the laptop for backups. Unfortunately, the drive was unreachable. In fact within Disk Management console the disk shows unintialized. After exhausting numerous resolutions, I decided too try to initialize it. Initialization fails with an I/O error (On morfe than two different computers).

with more investigating I think I found the problem. So, in between the actual 3TB drive and my USB3 port are two things one is the cable, and the other is the USB interface in the Essentials enclosure. From two different calls to WD Technical support, I received a new power supply and a new cable. Using either cable produces the same error.

If I were a betting man, I bet that the interface on the Essentials enclosure has failed! And I would even bet that if I found a method of removing the drive from the enclosure (Without voiding the warrantee or without falling out of “good graces” with WD) I bet I could regain access to my 20 -BLEEPing- years of software tools which I use daily that I entrusted WD products to store and continue providing me acces to (Sorry… I accidently ranted)!

Now I need to find some one who can do this without voiding the warrantee so I can retrieve my data and get this thing replaced by WD. Anyone know of a WD approved facility that can do this (Without breaking my ba…err bank?

-CaptFanSpaztic

If this is a drive that came with Smartware it is hardware encrypted so removing it from the enclosure won’t get you access to your data in a usable form. The drive might be corrupt if shows i disk Management so something like TestDisk http://www.cgsecurity.org/wiki/TestDisk might fix things.

Joe

Thanks for the reply Joe,

See that’s the interesting thing about this, If this were hardware encrypted shouldn’t we expect to see the drive at least initialized?

Would you mind pointing me to a link verifying that this drive is factory hardware encrypted?

No offense but is there a reason you’re hijacking my support topic? Your issues don’t seem to be similar to mine at all.

At this point i really just want to know if there’s a realistic chance of salvaging my data off the thing. If the adapter isn’t the issue, what needs to be fixed on the enclosure to get it working? I’m really exasperated as I’ve been searching online all day for answers and opened a ticket with WD but have had no luck.

Capt - having said that i guess we are both trying to find a way to get back access to our data, so if you do find an answer please let me know. I am almost positive that my actual hard drive is perfectly fine and it is merely the enclosure that is failing me somehow. I just dont know how to fix it or what the problem is. So frustrating.

All drives that come with Smartware hardware encrypted with the circuit board with the USB port. You can try finding another board on Ebay if that looks like the problem or an identical drive. Opening the case voids your warranty. This lnik may help a bit on the boards http://community.wdc.com/t5/Off-Topic-Discussions/Bridge-Boards/td-p/353839 

Joe

Really?!?! I mean seriously? You’re getting -like that- about someone else discussing what apears to be a very similar issue, and calling it “Hijacking a suppport topic”? Niiiiice.

Joe,

Again, thanks for your replies.

Yes, I understand that you are stating that the hardware is encrypted with the circuit board with the USB port. If you can point me to a link where this is documented, I would greatly appreicate it. Having the documentation will help when I take the drive to a WD Approved vendor who just as you and I know, that unless you are an approved WD vendor, opening the case voids the warranty.  Reviewing the link you provided, I learned a couple things

  1. It appears that the only way to know if this is a board issue and if I am affected by encryption, then the enclosure must be opened. Without going that far, I did a basic check and I can tell that the USB port on the enclosure feels secure (I know that it needs more detailed inspection though).

  2. Others have reported board issues.

I guess in the mean time, I’ll keep looking through WDs site for more documentation regarding this.

-CaptFanSpaztic

Yeah, I honestly thought it was a little rude of you to post your issues in my topic rather than creating your own, since your problems were quite different from what I was experiencing with my hard drive. I didn’t want to make a big deal out of it and even said I wasn’t trying to imply any offense, but now you’re trying to make me out to be the rude one when you essentially took over my support topic with your own separate technical issues. It’s just common forum etiquette, that’s all - three replies in you had basically redirected all the responses towards your situation. That being said I wish you good luck in solving your problems and hope you’re able to recover your data.

@Joe – thanks for info. If my issue is internal and has to do with the flimsy USB/PCB ports, do you know if taking my hard drive to a computer store where they may be able to solder them back together or whatever needs to be done, would void the warranty? And how simple do you think this would be to fix for someone who specializes in computer repair?

I actually got my hard drive to turn on last night and again a couple times today. Basically, I have to leave it disconnected from a power source for at least an hour, and then when I reconnect it to my computer, it boots up for about five minutes (and I’m able to read/write data to the drive) before it randomly disconnects from my computer. At that point, reconnecting the USB/power cable does nothing. It’s almost like I have to wait for it to ‘recharge’ somehow before it gets enough juice to work again. Really bizarre.

Wow,

I sincerely apologize for what may appear to be my taking over your topic. By reading your initial post, I honestly thought your situation was very similar to mine (I guess I just read things differently). With regards to me trying to make you out to be the rude one. No, I wasn’t trying to do that, I guess Its been a really long time since I’ve delt with forums and I never heard of Hijacking someones topic. Again, I apologize.

I’ll gladly start a new topic.

-CaptFanSpaztic

It’s probably been missing since day one.

The hardware is useless so you’re stuck with it.

In the UK, I bought mine at PC World and the idiot in the store a) couldn’t answer any of my questions, b) wasn’t allowed to show me a demonstration and c) said I could ONLY return it if it was faulty. I’m going to take mine back because it simply does not do what it purports itself to be able to do.

[Deleted]

I even answered a “customer services” survey from them (it took absolutely ages). This was months ago and despite some very negative feedback from me, they haven’t even acknowledged receipt of the survey or apologised.

This product should be removed from the shelves immediately but it won’t be of course because most people will settle for spending £150 on [Deleted]

How can you POSSIBLY ask for Kudos or “accepted solution” - are you some sort of “moderator” or “customer services representative”?

I’d go back to the place you bought it from as it’s still under warranty?

CaptFanSpaztic wrote:

 

  1. Others have reported board issues.

 

I guess in the mean time, I’ll keep looking through WDs site for more documentation regarding this.

 

-CaptFanSpaztic

 

Good luck with that!!! You’ll jolly well need it!