MyBook 3.0 3Tb disconnecting by itself

Good evening.

I think this is a bit different from other MyBook problems I’ve read at the community.

I`m having issues with an Western Digital My Book Essential 3.0 3 Tb. For 18 days I cannot use it because it has started disconnecting from the computer by itself (as if I had plugged it off) and connecting again. Now, when I connect it, it works for some 60 minutes (less if I try to move more than 4Gb from it to another drive) an then disappears from “My Computer” and produces some clicking noise.

Strange is, the external drive stays on and the computer recognizes there is some device connected, but I cannot access its files. My notebook is a Sony Vaio with Windows 7 Home Premium x64. I’ve got his HDD since June, by only by early October has it started malfuctioning.

I have tried to use it plugged to another computer, but I find the same issue.

Do you know if there is something I can do which does not involve losing my data?

Is the unit loosing power? or it stays on?

Did you try a different USB cable? Make sure you are not using a hub or a USB cable longer than the one supplied and try plugging power adapter straight into wall outlet instead of power strip. Try contacting Customer Service and see about a new power adapter. 


I have the 2 TB and the same thing happens to me. I sent in the first one, they replaced it and the second one is doing the same thing. Your files may not gone you just have to restart your computer. If that works I would move any files that you feel is important off of it. You can DL lifeguard and check the disk for bad sectors and if you have them you are basically SOL. I wish you good luck and hope you get your problem solved.

I am having the same issue as well. Using My Book Essential 3T. Tried plugging in directly to the wall and also to a different USB 2.0 port and same issue occurs within 3 minutes. It appears the problem is power related because the only way to connect it back is to plug it off and back on. Swtiching USB ports does not  connect the drive. I had another 2T drive 2 years ago and same issue started occuring. It is interesting to note that the drive works fine initially, but as soon as the amount of data reaches 50+% the disconnect starts happening and becomes more and more frequent as more data piles on. I think I need to find a different manufacturer for larger storage devices, as I am just about done with WDC. Very unfortunate and very sad to see that no solution has been found after 3 years of this drive’s existence.

Well, WD sent me a new drive with 3 TB and that drive is doing the same thing. I am fed up with this being this is the third time. The product is defective being I see I am not the only one with the same problem. WD has a policy where you can’t even get your money back if you are not satisfied. Made a big mistake getting a external drive from WD. I have externals from Seagate and they work.

I am glad I came to the discussion boards here. Was just about to purchase the WD My Book Live 3TB.

After reading these boards, I will probably buy something else.