MyBook 2TB Home Edition Triple Interface now appears as non-formatted on Windows or Mac


#1

With approximately 1TB of data on the drive & with less than a month’s use the drive now displays the following message when selected in Windows. “Drive _ is not formatted. Do you want to format now?” I tried updating the firmware with no success  http://support.wdc.com/product/download.asp?groupi d=111&sid=99&lang=en

This is the second drive which I’ve had this issue. Within a couple months of purchase, the first drive lost a 60GB block of data (photos that had been dumped into multiple directories ‘vanished’ a week after loading them). I ran recovery software and restored that chunk. It then lost a larger chunk which was restored. Finally the whole drive came up as unformatted at which time I had to warranty the drive in order to have something large enough to write to for recovery. Not all files were recovered. After its 3rd use this new warrantied drive is now doing the same thing. 

thank you


#2

I would have a look at your USB port. Those are pretty good drives. A problem like that could occur if it loses power or connection without being properly shut down. If something is wrong with the port, it could be causing loss of connection (at least to the OS)