Mybook 2TB for PC slowing down, couldn't read the MBR

I had a very worrisome incident last night.  I had connected and turned on a Mybook…and for the first time, the PC would not be able to read it.  It would read the “cd-rom” partitation but it would not see the main part of the drive. That is, read the MBR and recognize the contents.  I took it to two other computers and they were having trouble seeing it.  Unplugged it and tried again this morning…it read it…but performance is not great.  I began doing a data move operation and copied about 20GBs or so before it looked it was stalling out so I cancelled the copy and shut the drive off to “cool down”.  Just ran the WD Quick SMART test and it says it failed.  Earlier on it was saying it passed.  Needless to say I’m needing to get about a terrabyte of videos off of it copied to a 3TB Mybook small chunks at a time.  I also own ZAR 9.1 which I ran on the drive for a while but shut it off cause it stalled in the middle of the Quick Scan phase.  Any extra tips to help recover the data off this flakey drive?  It is possible to take the drive out of its enclosure and hook it up to the PC differently that’s effective?

If this is a drive that came with Smartware the data is hardware encrypted. So taking out of the case won’t help all you get is encrypted data. The drive may be corrupted.


Well it isn’t a corruption issue…today it took four tries to get the drive contents recognized.  Right now I’m copying data, but have to stop and let it sit for a while when it decides to fire a read error.  Read speeds vary but it does stall at times.

Well, the drive worked long enough for me to get everything off of it yesterday and today. But it does fail the Quick SMART and Quick Drive tests.  Really irritating that the thing was only a year and three months old and only half full when it decided to break down.