MyBook 2.0 TB USB 3.0 Keeps trying to disconnect and stopped by smartware

I have 2 WD my book on this computer.  A dell Desktop.  I have all my music on drive J:  which is the new USB 3.0 plugged into a 2.0 port.  I have a mirror back up drive M: which is USB 2.0 and working fine.  I have had drive J for a year and lately I have been having problems with the drive disconnecting and reconnecting.  A few weeks ago I tried to replace the cables.  That seemed to work but then 2 weeks later the problem happened again.  So this time I uninstalled and reinstalled the smartware software.  This seemed to work too, the drive was showing up in the smartware which it didnt before.  I figured that had been the problem.  But now a few weeks later it is happeneing again.  However this time instead of disconnecting then reconnecting I get a message from smartware saying that the drive cannot be disonnected while in use.  I hit the ok button the warning window goes away then pops back up a minute or 2 later.  I have made sure that my USB settings in windows do not power down.  My other external drive never does this.  I have run diagnostics on the drive and it checks ok.  I have no problems using the drive.   One time I did get a message that i needed to format the drive.  This has been going on for a couple months and I have tried all the suggested trouble shooting.  The only thing I havent done is update the firmware because I am afraid of losing the data.  Will updating the firmware fix this problem?

Hello Mate,

Update smartware to the latest version, also if possible backup your drive and run the WD DLG tool. As a last troubleshoot step write zeros to the unit using DLG.

1 Like

Thanks, I went and bought another 2 TB drive and am copying the drive.  Not what I wanted to do but 119.00 is cheap compared to the amount of money in music there is on it.  I have been backing up remotely using Carbonite, but I got that in november and it still is only about 25% done backing up.  Once my copy is done in about 8 hours I think I will update the firmware on the drive.  Then make sure my smartware is updated too.  Guess when this is all done Ill either have a local back up and a remote back up, or Ill have a drive i dont use and a remote back up.  Either way i spent the money now  :smiley:

Ill try the WD DLG tool if the problem happens again after updating firmware.  Thanks for the suggestions!