My WDTV box cannot see any Wireless networks at all


I’ve recently purchased a WDTV Live Streaming box and have spent about 3-4 hours trying to get it to work with WiFi. On powerup it searches for a Wireless Network but never manages to find (or list) any of them. However, I live in the middle of town and apart from mine, there are over 80 different WiFi networks of various flavours currently in range of my flat (as reported by this laptop).

In addition to the auto search function for the network I’ve also tried to manually specify my settings (which also fails). If I plug an ethernet cable in the device can get on the internet (but I bought the thing especially because of the specified internal Wifi connectivity).

I’ve upgraded to the latest version 1.10.13 and after this I’ve also tried downgrading to the 1.09.10 and 1.08.17 builds.

Has anyone ever seen this? Does it just sound like I have a hardware fault?



Have you tried moving the WDTV a little bit closer to the wireless router?