My WDBJRT0020BBK-0B shuts off after 4 minutes of PC being booted up

Hello, this is my first time posting here.

So I have this pretty annoying problem I have been dealing with for the past few weeks, and I cannot find the right solution. I have purchased a WD Elements SE Portable with 2TB storage last year and up until a couple of weeks it worked like a charm, but now it shuts off automatically after 4 minutes.

If I unplug the USB cable and replug it into my PC, the HDD does show up and it lets me read the data/transfer files onto the HDD but after the 4 minutes run out it shuts off with no warning at all + the fans in the HDD turn off.

Some solutions I have tried are:

  • Setting “Turn off hard disk after Setting (Minutes): Never” in the advanced power settings menu
  • Running a program/batch file that puts a dummy file onto the HDD and removes it right after
  • Updating the USB drivers in Device Manager
  • Plugging my USB cable into other USB ports (both 3.0 and 2.0 respectively)

Despite all trying all these solutions, my problem still stands. Could my HDD be severely damaged? Why would it let me access my files nonetheless? Once during class I asked someone to try out his USB cable and plug it into mine onto a computer, but it still kept happening. This caused another problem where my HDD is only accessable on my own PC, but not the one from somebody else. It shows the HDD I cannot access it.

If you have experience with this problem in the past and you fixed it or whatever, please let me know.


EDIT: Forgot to say, I installed WD Drive Utilities right before I made this thread and that didn’t resolve it either, doing a scan gave me nothing.

there are no fans inside a 2TB WD Elements SE Portable (or any other WD 2.5" USB Portable drives for that matter)

i have 3x 2TB WD ELements SE Portables and 2x 1TB WD Elements SE Portables + a whole bunch more WD USB Portables.

Have never heard of or had an “exact” 4 min shutdown problem ever.

Try a different USB Portable hard drive or contact WD Support and Submit an RMA for your drive because something does not sound right.

My apologies, by fan I forgot that it’s actually the platters that are moving inside of it.

I used a stopwatch to see how long it was connected to my PC before it shuts off so that’s why I mentioned 4 minutes.

The last one could possibly help me out. Could you link me the page to contact WD Support/Submit an RMA to?