My WD TV LIve USED to work

purchased this unit about a year ago and had decent success with it.  I used to have it hooked to a 1TB WD external and a 32" Vizio LCD.  there were some quirks, and every so often i would come across a file that wouldn’t play.  no big deal.  that was then…

now… i moved the unit to a new Panasonic S series 50" plasma and did a firmware update.  what a clusterf*&^.  still using the same WD 1TB external.

 nothing works right.  movies that used to play flawless are a mess.  i have mostly .mkv’s, but it seems all formats are affected.  issues…

  1. the only way i can even get a file to play is to let the preview start, highlight it, and hit enter.  if i press play or enter from the listing or “list view”, all i get is a blank screen.

  2. FF and REW will only work in the preview screen.  if either are selected while the actual file is playing they freeze up and will continue to jump ahead or back no matter what is pressed on the remote.  eventually, the player reverts back to the file listing page.  the remote becomes useless until this happens.

3.  some files don’t even play the preview (files that previously worked fine).

i have rolled back firmware to no avail, changed about every setting dealing with video output, restored defaults, etc.  nothing helps.  the only thing i haven’t tried is moving it back to the 32" VIzio TV.

i’m a patient person, but i’ve gotten to the point where this little box is hitting the wall soon.  any advice is welcome.

If this all started after the firmware update, then roll back to the prior release.

This latest version is pretty heavily flawed.

thanks, but i have gone back to both available firmwares (on the WD site).  neither helped.  i know that the firmwares are installing, because the internet apps change and i then get the option to upgrade.

i would be willing to go all the way back to the original version, but i can’t find it anywhere.

thanks tho.

Sorry, I didn’t read all the way to the end… 

If rolling back didn’t fix your issue, then it’s apparent that it’s not a firmware update issue.

But I think you’re on the right track;  undo the changes.   Although I can’t imagine why the TV would affect the ability to play a specific file, I guess it’s worth a try.   

Now this POS will only recognize 1/2 of the folders on my external (and I only have 4 total).  It’s not the external because my laptop sees everything fine when plugged in. 

i tried to hard reset the box.  same result.  how long is the warranty on these?

A year, unless you live in Europe.  ;)

There’s (usually) a simple fix to this latest issue.

Take your drive to your PC, and find the folder called .wd-tv and delete it and everything in the folder.

That’s the Media Library and it can get out of whack.

1-  It’s a good idea to wait until the Media Library is finished building before you start browsing files. (The WD logo will stop flashing.)

2-  ALWAYS Eject the disk before removing it or powering down the WDTV.

3-  NEVER eject the disk when the Media Library is compiling.

Let me know if that helps.