My WD Passport WDBBEP0010BBK-01 doesn't reach USB 3.0 Speed


I have the external drive from WD WDBBEP0010BBK-01.

My OS is Windows 7 Ultimate x64 running on HP Pavilion dv7-6c02sm

My drivers are up to date and i tested my computers USB 3.0 with another USB 3.0 device and that one reaches 100 Mb/s without problem and then falls to 60 MB/s and continues with that speed which is acceptable.

But the WD drive reaches only 20 Mb/s when pluged in the USB 3.0 sometimes even works with 13 Mb/s or less and this is not acceptable. Also with testing I saw that it works a bit faster when pluged into USB 2.0.

I have the WD drive for about 6 months and i newer used USB 3.0 before because my old computer didn’t have USB 3.0

Now on my new computer the disk doesn’t work at the USB 3.0 Speed.

I formated the disk and tried again. Nothing changes. 

Please provide me some description of the files maybe needed on the WD Drive to support USB 3.0 because I formated the drive. Also before that while using it I deleted the files on WD drive.

Thanks in advance


I checked the drive on another computer and it is working fine.Maybe there is some compatibility issue with my drivers. A normal USB 3.0 SanDisk is working fine on USB 3.0 but WD doesn’t.

Will post more information when it will be clearer what exactly is the problem.


OK … I solved the mistery  :smiley:

After hours an hours of searching online i figured out it is most of all a windows 7 problem because of the windows updates were not installed to the end. At the end only one USB was working with 3.0 but there was an  optional  windows update to install and atfer installing the optional update ( involved something with system ) both of USB 3.0 are working at a speed of 120 Mb/s  :smiley: