My WD passport doesn't appear in My Computer!

Hi everyone,

Simply my WD Passport doesn’t appear in My Computer. It appears in Device Proprieties, in the control panel under Devices, but not in My Computer so i can’t access to see files inside it.

can you pls help ? I have very important documents in my passport :frowning:


Is your WD Passport displayed within Microsoft Windows Disk Management? If so, does it list a healthy partition, or raw space? IS your WD Passport encrypted? Was it recently connected to an Apple Mac computer?

In order to access Disk Management please visit the following link:

Im having the exact same problem with a HD that I bought 2 months ago!

Mine does not appear under Device Management.  I typically like WD products, so I’ really like for this to not be the last one I buy, but it was my back-up hard drive.

Any other thoughts?

Same problem here. Shows up in Device Manager under Hard Drives: WD My Passport 0830 USB Device, Also shows as: WD drive Management devices, and USB Mass Storage device. It does not show in My Computer or in Disk Management. Have tried uninstalling and restarting several times. It does’t work. Worked on another XP computer. Trying to backup files to upgrade to Win 7.