My WD Passport 500GB is not copying files

My WD Passport 500GB all of a sudden started giving errors in connecting , the drive when plugged would not show up in  My computer nor in the Disk management , once it miraculously got visible in the disk management from there I tried to format it but it refused. While all this whenever the drive was plugged the light on the drive would blink showing that it was connected. 

Then I plugged it to my XBOX 360 and formatted it from there after that the drive started working but once I started copying data into it after like 15GB the drive again went to give errors not it gets detected but when I try to copy anything in it it starts very slow almost 100s of KBs per sec which is very slow, and half way down it would give error that the data cannot be copied. 

I tried to check it with WD Data Life Guard diagnostic tool which first test Quick test failed, you can find the image of the errors on the b/m link.

Is there any one that can help me in resolving this issue for my drive. Or would you have any suggestions. 

The drive needs to be replaced