My WD My Passport Ultra is not recognised by my Blu-ray Player

#1

Hi, I’d appreciate if anyone could help me solving my problem. I’ve been connecting my Buffalo 500Gb hard drive which runs with NTFS with my Blu-ray player Pioneer BDP 3110 and it worked every time immediately no matter I plug it in when the player is turned on or off.

Recently I’ve purchased this WD My Passport Ultra 1Tb hard drive but it cannot be recognised by my player. I’ve done all the research and solution found on forums but it just couldn’t work. The blu-ray player supports NTFS and could read drives up to 2Tb memory. I’ve even run an upgrade of firmware for my player. I tried to connect my hard drive before turning on my player and etc… Nothing worked!

Is there any other suggestion/solution? Would appreciate for anyone who could help me.

Thank you!

My 4T Passport Ultra, not visible, not connecting to DVD/Movie player
#2

Check the partition type on the Passport and see if it’s GPT or MBR. I’d imagine your BD Player definitely supports MBR, but if the Passport is GPT, it might not support it.

If that’s the case, you should be able to format the Passport using an MBR partition.

#3

That pretty says your Pioneer only supports MBR

(because GPT Partition Style is required for HDDs over 2TB … but, WD seem to be formatting all their drives now with GPT partitions … even if they are less than 2TB)

1 Like
#4

Ok, will try converting it. Thank you!

#5

Yes it worked! Thank you so much!

#6

Good to hear :slight_smile: please mark your post as “Solved”

1 Like
#7

Sure thing. :slight_smile: